miniupnpc: update to version 2.2.3
Signed-off-by: Shaleen Jain <shaleen@jain.sh>
This commit is contained in:
parent
c2e846dae6
commit
82010861aa
3 changed files with 31 additions and 4 deletions
|
@ -8,12 +8,12 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=miniupnpc
|
PKG_NAME:=miniupnpc
|
||||||
PKG_VERSION:=2.2.2
|
PKG_VERSION:=2.2.3
|
||||||
PKG_RELEASE:=$(AUTORELEASE)
|
PKG_RELEASE:=$(AUTORELEASE)
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=https://miniupnp.tuxfamily.org/files
|
PKG_SOURCE_URL:=https://miniupnp.tuxfamily.org/files
|
||||||
PKG_HASH:=888fb0976ba61518276fe1eda988589c700a3f2a69d71089260d75562afd3687
|
PKG_HASH:=dce41b4a4f08521c53a0ab163ad2007d18b5e1aa173ea5803bd47a1be3159c24
|
||||||
|
|
||||||
PKG_MAINTAINER:=
|
PKG_MAINTAINER:=
|
||||||
PKG_LICENSE:=BSD-3-Clause
|
PKG_LICENSE:=BSD-3-Clause
|
||||||
|
|
|
@ -13,3 +13,30 @@
|
||||||
# Suppress noise warnings
|
# Suppress noise warnings
|
||||||
if (MSVC)
|
if (MSVC)
|
||||||
target_compile_definitions(miniupnpc-private INTERFACE _CRT_SECURE_NO_WARNINGS)
|
target_compile_definitions(miniupnpc-private INTERFACE _CRT_SECURE_NO_WARNINGS)
|
||||||
|
@@ -221,16 +215,16 @@ endif ()
|
||||||
|
|
||||||
|
if (NOT UPNPC_NO_INSTALL)
|
||||||
|
install (FILES
|
||||||
|
- miniupnpc.h
|
||||||
|
- miniwget.h
|
||||||
|
- upnpcommands.h
|
||||||
|
- igd_desc_parse.h
|
||||||
|
- upnpreplyparse.h
|
||||||
|
- upnperrors.h
|
||||||
|
- upnpdev.h
|
||||||
|
- miniupnpctypes.h
|
||||||
|
- portlistingparse.h
|
||||||
|
- miniupnpc_declspec.h
|
||||||
|
+ include/miniupnpc.h
|
||||||
|
+ include/miniwget.h
|
||||||
|
+ include/upnpcommands.h
|
||||||
|
+ include/igd_desc_parse.h
|
||||||
|
+ include/upnpreplyparse.h
|
||||||
|
+ include/upnperrors.h
|
||||||
|
+ include/upnpdev.h
|
||||||
|
+ include/miniupnpctypes.h
|
||||||
|
+ include/portlistingparse.h
|
||||||
|
+ include/miniupnpc_declspec.h
|
||||||
|
DESTINATION include/miniupnpc
|
||||||
|
)
|
||||||
|
|
||||||
|
|
|
@ -1,5 +1,5 @@
|
||||||
--- a/upnpcommands.c
|
--- a/src/upnpcommands.c
|
||||||
+++ b/upnpcommands.c
|
+++ b/src/upnpcommands.c
|
||||||
@@ -371,7 +371,7 @@ UPNP_AddPortMapping(const char * control
|
@@ -371,7 +371,7 @@ UPNP_AddPortMapping(const char * control
|
||||||
AddPortMappingArgs[5].elt = "NewEnabled";
|
AddPortMappingArgs[5].elt = "NewEnabled";
|
||||||
AddPortMappingArgs[5].val = "1";
|
AddPortMappingArgs[5].val = "1";
|
||||||
|
|
Loading…
Reference in a new issue