gptfdisk: update to 1.0.6
Remove all uclibcxx support. It's buggy and fairly dead upstream. Remove libcxx linker hack attributed to glibc. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
066f2049ba
commit
816961484c
2 changed files with 4 additions and 87 deletions
|
@ -8,12 +8,12 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=gptfdisk
|
PKG_NAME:=gptfdisk
|
||||||
PKG_VERSION:=1.0.5
|
PKG_VERSION:=1.0.6
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=@SF/$(PKG_NAME)
|
PKG_SOURCE_URL:=@SF/$(PKG_NAME)
|
||||||
PKG_HASH:=0e7d3987cd0488ecaf4b48761bc97f40b1dc089e5ff53c4b37abe30bc67dcb2f
|
PKG_HASH:=ddc551d643a53f0bd4440345d3ae32c49b04a797e9c01036ea460b6bb4168ca8
|
||||||
|
|
||||||
PKG_MAINTAINER:=Alif M. Ahmad <alive4ever@live.com>
|
PKG_MAINTAINER:=Alif M. Ahmad <alive4ever@live.com>
|
||||||
PKG_LICENSE:=GPL-2.0-or-later
|
PKG_LICENSE:=GPL-2.0-or-later
|
||||||
|
@ -21,7 +21,6 @@ PKG_LICENSE_FILES:=COPYING
|
||||||
|
|
||||||
PKG_BUILD_PARALLEL:=1
|
PKG_BUILD_PARALLEL:=1
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/uclibc++.mk
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
define Package/gptfdisk/Default
|
define Package/gptfdisk/Default
|
||||||
|
@ -29,7 +28,7 @@ define Package/gptfdisk/Default
|
||||||
CATEGORY:=Utilities
|
CATEGORY:=Utilities
|
||||||
SUBMENU:=Disc
|
SUBMENU:=Disc
|
||||||
URL:=https://www.rodsbooks.com/gdisk
|
URL:=https://www.rodsbooks.com/gdisk
|
||||||
DEPENDS:=$(CXX_DEPENDS)
|
DEPENDS:=+libstdcpp
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/gdisk
|
define Package/gdisk
|
||||||
|
@ -74,10 +73,7 @@ define Package/fixparts/description
|
||||||
endef
|
endef
|
||||||
|
|
||||||
TARGET_CXXFLAGS += -std=c++11 -ffunction-sections -fdata-sections -fno-rtti -flto
|
TARGET_CXXFLAGS += -std=c++11 -ffunction-sections -fdata-sections -fno-rtti -flto
|
||||||
TARGET_LDFLAGS += $(if $(CONFIG_USE_GLIBC),-lm) -Wl,--gc-sections,--as-needed
|
TARGET_LDFLAGS += -Wl,--gc-sections,--as-needed
|
||||||
ifeq ($(CONFIG_USE_UCLIBCXX),y)
|
|
||||||
TARGET_LDFLAGS += -nodefaultlibs
|
|
||||||
endif
|
|
||||||
|
|
||||||
define Package/gdisk/install
|
define Package/gdisk/install
|
||||||
$(INSTALL_DIR) $(1)/usr/bin
|
$(INSTALL_DIR) $(1)/usr/bin
|
||||||
|
|
|
@ -1,79 +0,0 @@
|
||||||
From b33f93bea332211afae037e4b6f379f0876302d1 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Rosen Penev <rosenp@gmail.com>
|
|
||||||
Date: Tue, 8 Oct 2019 20:51:54 -0700
|
|
||||||
Subject: [PATCH] Add some extra flushes before getline/cin
|
|
||||||
|
|
||||||
These are not covered by the previous commits.
|
|
||||||
|
|
||||||
Signed-off-by: Rosen Penev <rosenp@gmail.com>
|
|
||||||
---
|
|
||||||
diskio-unix.cc | 2 +-
|
|
||||||
gptcurses.cc | 4 ++--
|
|
||||||
parttypes.cc | 2 +-
|
|
||||||
support.cc | 2 +-
|
|
||||||
4 files changed, 5 insertions(+), 5 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/diskio-unix.cc b/diskio-unix.cc
|
|
||||||
index d9f8b8d..c38fda5 100644
|
|
||||||
--- a/diskio-unix.cc
|
|
||||||
+++ b/diskio-unix.cc
|
|
||||||
@@ -92,7 +92,7 @@ int DiskIO::OpenForRead(void) {
|
|
||||||
#if defined(__linux__) && !defined(EFI)
|
|
||||||
if (isOpen && realFilename.substr(0,4) == "/dev") {
|
|
||||||
ostringstream modelNameFilename;
|
|
||||||
- modelNameFilename << "/sys/block" << realFilename.substr(4,512) << "/device/model";
|
|
||||||
+ modelNameFilename << "/sys/block" << realFilename.substr(4,512) << "/device/model" << flush;
|
|
||||||
ifstream modelNameFile(modelNameFilename.str().c_str());
|
|
||||||
if (modelNameFile.is_open()) {
|
|
||||||
getline(modelNameFile, modelName);
|
|
||||||
diff --git a/gptcurses.cc b/gptcurses.cc
|
|
||||||
index 4ebfde1..ca6f4ea 100644
|
|
||||||
--- a/gptcurses.cc
|
|
||||||
+++ b/gptcurses.cc
|
|
||||||
@@ -422,7 +422,7 @@ void GPTDataCurses::Verify(void) {
|
|
||||||
def_prog_mode();
|
|
||||||
endwin();
|
|
||||||
GPTData::Verify();
|
|
||||||
- cout << "\nPress the <Enter> key to continue: ";
|
|
||||||
+ cout << "\nPress the <Enter> key to continue: " << flush;
|
|
||||||
cin.get(junk);
|
|
||||||
reset_prog_mode();
|
|
||||||
refresh();
|
|
||||||
@@ -820,7 +820,7 @@ void ShowTypes(void) {
|
|
||||||
def_prog_mode();
|
|
||||||
endwin();
|
|
||||||
tempType.ShowAllTypes(LINES - 3);
|
|
||||||
- cout << "\nPress the <Enter> key to continue: ";
|
|
||||||
+ cout << "\nPress the <Enter> key to continue: " << flush;
|
|
||||||
cin.get(junk);
|
|
||||||
reset_prog_mode();
|
|
||||||
refresh();
|
|
||||||
diff --git a/parttypes.cc b/parttypes.cc
|
|
||||||
index cd225d1..6c2c8c6 100644
|
|
||||||
--- a/parttypes.cc
|
|
||||||
+++ b/parttypes.cc
|
|
||||||
@@ -530,7 +530,7 @@ void PartType::ShowAllTypes(int maxLines) const {
|
|
||||||
|
|
||||||
cout.unsetf(ios::uppercase);
|
|
||||||
if (maxLines > 0) {
|
|
||||||
- cout << "Type search string, or <Enter> to show all codes: ";
|
|
||||||
+ cout << "Type search string, or <Enter> to show all codes: " << flush;
|
|
||||||
matchString = ToLower(ReadString());
|
|
||||||
} // if
|
|
||||||
while (thisType != NULL) {
|
|
||||||
diff --git a/support.cc b/support.cc
|
|
||||||
index 891caad..645ef5d 100644
|
|
||||||
--- a/support.cc
|
|
||||||
+++ b/support.cc
|
|
||||||
@@ -127,7 +127,7 @@ uint64_t GetSectorNum(uint64_t low, uint64_t high, uint64_t def, uint64_t sSize,
|
|
||||||
char line[255];
|
|
||||||
|
|
||||||
do {
|
|
||||||
- cout << prompt;
|
|
||||||
+ cout << prompt << flush;
|
|
||||||
cin.getline(line, 255);
|
|
||||||
if (!cin.good())
|
|
||||||
exit(5);
|
|
||||||
--
|
|
||||||
2.17.1
|
|
||||||
|
|
Loading…
Reference in a new issue