stress-ng: bump to version 0.15.10
Merged patches into a single one. Disabling libmpfr (which got added recently). To avoid potentially new build failures. And disabling test-compiler check. Signed-off-by: Alexandru Ardelean <alex@shruggie.ro>
This commit is contained in:
parent
2ee93efe5d
commit
8168fc84df
5 changed files with 30 additions and 24 deletions
|
@ -6,12 +6,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=stress-ng
|
||||
PKG_VERSION:=0.15.06
|
||||
PKG_VERSION:=0.15.10
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/ColinIanKing/stress-ng/tar.gz/refs/tags/V$(PKG_VERSION)?
|
||||
PKG_HASH:=c38cefcf0a83f6c65aed7c36e57a9a1ee8373418ef71cf089a75b0661dcd4623
|
||||
PKG_HASH:=fcd86e1b8db5b2c22182cefbf4b3131a8599bff5bdd85edf776ec15c2d80e8f1
|
||||
|
||||
PKG_MAINTAINER:=Alexandru Ardelean <ardeleanalex@gmail.com>
|
||||
PKG_LICENSE:=GPL-2.0-only
|
||||
|
|
15
utils/stress-ng/patches/001-disable-extra-stressors.patch
Normal file
15
utils/stress-ng/patches/001-disable-extra-stressors.patch
Normal file
|
@ -0,0 +1,15 @@
|
|||
--- a/Makefile.config
|
||||
+++ b/Makefile.config
|
||||
@@ -319,9 +319,9 @@ compiler: configdir
|
||||
libraries: \
|
||||
compiler \
|
||||
LIB_AIO LIB_APPARMOR LIB_BSD LIB_CRYPT LIB_DL \
|
||||
- LIB_EGL LIB_GBM LIB_GLES2 LIB_IPSEC_MB LIB_JPEG \
|
||||
- LIB_JUDY LIB_KMOD LIB_MD LIB_MPFR LIB_PTHREAD LIB_PTHREAD_SPINLOCK \
|
||||
- LIB_RT LIB_SCTP LIB_XXHASH LIB_Z
|
||||
+ LIB_IPSEC_MB LIB_JPEG \
|
||||
+ LIB_JUDY LIB_KMOD LIB_MD LIB_PTHREAD LIB_PTHREAD_SPINLOCK \
|
||||
+ LIB_RT LIB_SCTP LIB_Z
|
||||
|
||||
LIB_AIO: compiler
|
||||
$(call check,test-libaio,HAVE_LIB_AIO,$(LIB_AIO),$(LIB_AIO))
|
|
@ -1,11 +0,0 @@
|
|||
--- a/Makefile.config
|
||||
+++ b/Makefile.config
|
||||
@@ -264,7 +264,7 @@ clean:
|
||||
libraries: \
|
||||
configdir \
|
||||
LIB_AIO LIB_APPARMOR LIB_BSD LIB_CRYPT LIB_DL \
|
||||
- LIB_EGL LIB_GBM LIB_GLES2 LIB_IPSEC_MB LIB_JPEG \
|
||||
+ LIB_IPSEC_MB LIB_JPEG \
|
||||
LIB_JUDY LIB_KMOD LIB_MD LIB_PTHREAD LIB_PTHREAD_SPINLOCK \
|
||||
LIB_RT LIB_SCTP LIB_XXHASH LIB_Z
|
||||
|
13
utils/stress-ng/patches/002-disable-compiler-test.patch
Normal file
13
utils/stress-ng/patches/002-disable-compiler-test.patch
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- a/Makefile.config
|
||||
+++ b/Makefile.config
|
||||
@@ -309,10 +309,6 @@ clean:
|
||||
@rm -rf $(CONFIGS) config config.h
|
||||
|
||||
compiler: configdir
|
||||
- @echo "checking compiler ..."
|
||||
- @$(CC) test/test-compiler.c -o test/test-compiler
|
||||
- @echo "" > $(CONFIGS)/$$(./test/test-compiler)
|
||||
- @rm -f test/test-compiler
|
||||
$(call check,test-glibc,HAVE_GLIBC,using glibc)
|
||||
|
||||
.PHONY: libraries
|
|
@ -1,11 +0,0 @@
|
|||
--- a/Makefile.config
|
||||
+++ b/Makefile.config
|
||||
@@ -266,7 +266,7 @@ libraries: \
|
||||
LIB_AIO LIB_APPARMOR LIB_BSD LIB_CRYPT LIB_DL \
|
||||
LIB_IPSEC_MB LIB_JPEG \
|
||||
LIB_JUDY LIB_KMOD LIB_MD LIB_PTHREAD LIB_PTHREAD_SPINLOCK \
|
||||
- LIB_RT LIB_SCTP LIB_XXHASH LIB_Z
|
||||
+ LIB_RT LIB_SCTP LIB_Z
|
||||
|
||||
LIB_AIO:
|
||||
$(call check,test-libaio,HAVE_LIB_AIO,$(LIB_AIO),$(LIB_AIO))
|
Loading…
Reference in a new issue