mail: add greyfix
Signed-off-by: Lucian Cristian <lucian.cristian@gmail.com>
This commit is contained in:
parent
15b1d7a522
commit
801834470b
2 changed files with 86 additions and 0 deletions
46
mail/greyfix/Makefile
Normal file
46
mail/greyfix/Makefile
Normal file
|
@ -0,0 +1,46 @@
|
|||
#
|
||||
# Copyright (C) 2017 Lucian Cristian <lucian.cristian@gmail.com>
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=greyfix
|
||||
PKG_VERSION:=0.4.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE_URL:=http://www.kim-minh.com/pub/greyfix
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_HASH:=26013edce3a38d586282bfc22eb91bd22df54e3558ea1b3dae54d3e7a769e4fe
|
||||
|
||||
MAINTAINER:=Lucian Cristian <lucian.cristian@gmail.com>
|
||||
PKG_LICENSE:=GPLv2
|
||||
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/greyfix
|
||||
SECTION:=mail
|
||||
CATEGORY:=Mail
|
||||
DEPENDS:=+libdb47
|
||||
TITLE:=Greyfix - greylisting with Postfix.
|
||||
URL:=http://www.kim-minh.com/pub/greyfix/
|
||||
endef
|
||||
|
||||
define Package/greyfix/description
|
||||
Greyfix is the greylisting policy daemon for Postfix written by Kim Minh Kaplan.
|
||||
endef
|
||||
|
||||
CONFIGURE_ARGS += \
|
||||
--localstatedir=/usr/lib \
|
||||
|
||||
define Package/greyfix/install
|
||||
$(INSTALL_DIR) $(1)/usr/sbin \
|
||||
$(1)/usr/lib/greyfix
|
||||
$(CP) $(PKG_BUILD_DIR)/greyfix $(1)/usr/sbin/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,greyfix))
|
40
mail/greyfix/patches/100-ignore_cross_compile_test.patch
Normal file
40
mail/greyfix/patches/100-ignore_cross_compile_test.patch
Normal file
|
@ -0,0 +1,40 @@
|
|||
--- a/configure 2017-03-08 20:12:00.720885949 +0200
|
||||
+++ b/configure 2017-03-08 20:12:51.210722711 +0200
|
||||
@@ -4190,37 +4190,6 @@
|
||||
|
||||
fi
|
||||
|
||||
-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking match between Berkeley DB header files and runtime" >&5
|
||||
-$as_echo_n "checking match between Berkeley DB header files and runtime... " >&6; }
|
||||
-if test "$cross_compiling" = yes; then :
|
||||
- { { $as_echo "$as_me:${as_lineno-$LINENO}: error: in \`$ac_pwd':" >&5
|
||||
-$as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
|
||||
-as_fn_error $? "cannot run test program while cross compiling
|
||||
-See \`config.log' for more details" "$LINENO" 5; }
|
||||
-else
|
||||
- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
||||
-/* end confdefs.h. */
|
||||
-#include <db.h>
|
||||
-int
|
||||
-main ()
|
||||
-{
|
||||
-int M, m; db_version(&M, &m, 0);
|
||||
- return DB_VERSION_MAJOR != M || DB_VERSION_MINOR != m;
|
||||
- ;
|
||||
- return 0;
|
||||
-}
|
||||
-_ACEOF
|
||||
-if ac_fn_c_try_run "$LINENO"; then :
|
||||
-
|
||||
-else
|
||||
- as_fn_error $? "Berkeley DB header file does not match the library file" "$LINENO" 5
|
||||
-fi
|
||||
-rm -f core *.core core.conftest.* gmon.out bb.out conftest$ac_exeext \
|
||||
- conftest.$ac_objext conftest.beam conftest.$ac_ext
|
||||
-fi
|
||||
-
|
||||
-{ $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
|
||||
-$as_echo "yes" >&6; }
|
||||
ac_config_files="$ac_config_files Makefile"
|
||||
|
||||
cat >confcache <<\_ACEOF
|
Loading…
Reference in a new issue