Merge pull request #8842 from ysc3839/tr-web-control
transmission-web-control: add new package
This commit is contained in:
commit
7fea6570e5
3 changed files with 64 additions and 0 deletions
41
net/transmission-web-control/Makefile
Normal file
41
net/transmission-web-control/Makefile
Normal file
|
@ -0,0 +1,41 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=transmission-web-control
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_URL:=https://github.com/ronggang/transmission-web-control
|
||||
PKG_SOURCE_DATE:=2019-04-16
|
||||
PKG_SOURCE_VERSION:=a747a87babb246b0d3e6dd108ad7b4c19462cfe6
|
||||
PKG_MIRROR_HASH:=90a2e33bd799a13504881e26980823fa181b47918900fc4ef03ae3daf0625f14
|
||||
|
||||
PKG_LICENSE:=MIT
|
||||
PKG_LICENSE_FILES:=LICENSE
|
||||
PKG_MAINTAINER:=Richard Yu <yurichard3839@gmail.com>
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/transmission-web-control
|
||||
SECTION:=net
|
||||
CATEGORY:=Network
|
||||
SUBMENU:=BitTorrent
|
||||
DEPENDS:=@(PACKAGE_transmission-daemon-openssl||PACKAGE_transmission-daemon-mbedtls)
|
||||
CONFLICTS:=transmission-web
|
||||
TITLE:=Transmission Web Control
|
||||
URL:=https://github.com/ronggang/transmission-web-control
|
||||
PKGARCH:=all
|
||||
endef
|
||||
|
||||
define Package/transmission-web-control/description
|
||||
Transmission Web Control is a custom Web UI for Transmission.
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
endef
|
||||
|
||||
define Package/transmission-web-control/install
|
||||
$(INSTALL_DIR) $(1)/usr/share/transmission/web
|
||||
$(CP) $(PKG_BUILD_DIR)/src/* $(1)/usr/share/transmission/web
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,transmission-web-control))
|
|
@ -0,0 +1,22 @@
|
|||
--- a/src/index.html
|
||||
+++ b/src/index.html
|
||||
@@ -61,9 +61,6 @@
|
||||
<!-- 切换到移动版 -->
|
||||
<a id="toolbar_mobile" href="javascript:location.href = 'index.mobile.html';" class="easyui-linkbutton" data-options="iconCls:'icon-mobile',plain:true" system-tip-lang="toolbar.tip['ui-mobile']"><span system-lang="toolbar['ui-mobile']"></span></a>
|
||||
<span class="button-split">|</span>
|
||||
- <!-- 切换到原版 -->
|
||||
- <a id="" href="javascript:location.href = 'index.original.html';" class="easyui-linkbutton" data-options="iconCls:'icon-transmission',plain:true" system-tip-lang="toolbar.tip['ui-original']"><span system-lang="toolbar['ui-original']"></span></a>
|
||||
- <span class="button-split">|</span>
|
||||
<!-- 关于 -->
|
||||
<a id="toolbar_about" href="javascript:void(0);" onclick="javascript:system.openDialogFromTemplate({id: 'dialog-about',options: {title: system.lang.toolbar['about'],width: 420,height: 370}});" class="easyui-linkbutton" data-options="iconCls:'icon-about',plain:true" system-tip-lang="toolbar.about"><span system-lang="toolbar.about"></span></a>
|
||||
</div>
|
||||
--- a/src/index.mobile.html
|
||||
+++ b/src/index.mobile.html
|
||||
@@ -69,7 +69,6 @@
|
||||
<ul data-role="listview" data-divider-theme="a" data-theme="c" data-icon="false" style="margin-top:15px;">
|
||||
<li data-role='list-divider'>UI</li>
|
||||
<li><a href="#" onclick="location.href = 'index.html?devicetype=computer';"><img src="tr-web-control/style/images/computer.png" class="ui-li-icon"/><span system-lang="toolbar['ui-computer']"></span></a></li>
|
||||
- <li><a href="#" onclick="location.href = 'index.original.html';"><img src="tr-web-control/style/images/transmission.png" class="ui-li-icon"/><span system-lang="toolbar['ui-original']"></span></a></li>
|
||||
</ul>
|
||||
<ul data-role="listview" data-divider-theme="a" data-theme="c" data-icon="false" style="margin-top:15px;">
|
||||
<li data-role='list-divider'><span system-lang="title.status"></span></li>
|
|
@ -86,6 +86,7 @@ define Package/transmission-web
|
|||
$(call Package/transmission/template)
|
||||
TITLE+= (webinterface)
|
||||
DEPENDS:=@(PACKAGE_transmission-daemon-openssl||PACKAGE_transmission-daemon-mbedtls)
|
||||
CONFLICTS:=transmission-web-control
|
||||
PKGARCH:=all
|
||||
endef
|
||||
|
||||
|
|
Loading…
Reference in a new issue