Merge pull request #10764 from neheb/bf
bfdd: Fix compilation with uClibc-ng
This commit is contained in:
commit
7f669d8d7c
2 changed files with 16 additions and 1 deletions
|
@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=bfdd
|
PKG_NAME:=bfdd
|
||||||
PKG_SOURCE_DATE:=2019-08-22
|
PKG_SOURCE_DATE:=2019-08-22
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=2
|
||||||
|
|
||||||
PKG_SOURCE_VERSION:=c54534beb524afc3972039f57b56ec65332b43f7
|
PKG_SOURCE_VERSION:=c54534beb524afc3972039f57b56ec65332b43f7
|
||||||
PKG_SOURCE_URL:=https://codeload.github.com/rzalamena/bfdd/tar.gz/$(PKG_SOURCE_VERSION)?
|
PKG_SOURCE_URL:=https://codeload.github.com/rzalamena/bfdd/tar.gz/$(PKG_SOURCE_VERSION)?
|
||||||
|
@ -46,6 +46,8 @@ define Package/bfdd/conffiles
|
||||||
/etc/bfdd/bfdd.json
|
/etc/bfdd/bfdd.json
|
||||||
endef
|
endef
|
||||||
|
|
||||||
|
TARGET_CFLAGS += -D_GNU_SOURCE
|
||||||
|
|
||||||
define Package/bfdd/install
|
define Package/bfdd/install
|
||||||
$(INSTALL_DIR) \
|
$(INSTALL_DIR) \
|
||||||
$(1)/usr/sbin \
|
$(1)/usr/sbin \
|
||||||
|
|
13
net/bfdd/patches/010-uclibc.patch
Normal file
13
net/bfdd/patches/010-uclibc.patch
Normal file
|
@ -0,0 +1,13 @@
|
||||||
|
diff --git a/bfd_packet.c b/bfd_packet.c
|
||||||
|
index e8f99f9..2c9fa91 100644
|
||||||
|
--- a/bfd_packet.c
|
||||||
|
+++ b/bfd_packet.c
|
||||||
|
@@ -29,6 +29,8 @@
|
||||||
|
#define _UAPI_IPV6_H
|
||||||
|
#endif /* _UAPI_IPV6_H */
|
||||||
|
|
||||||
|
+#define _GNU_SOURCE
|
||||||
|
+
|
||||||
|
#include <linux/filter.h>
|
||||||
|
#include <linux/if_ether.h>
|
||||||
|
#include <linux/if_packet.h>
|
Loading…
Reference in a new issue