Merge pull request #17531 from neheb/1
fuse: fix compilation with recent glibc
This commit is contained in:
commit
7f5484fc9d
2 changed files with 21 additions and 1 deletions
|
@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
|
|||
|
||||
PKG_NAME:=fuse
|
||||
PKG_VERSION:=2.9.9
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://github.com/libfuse/libfuse/releases/download/$(PKG_NAME)-$(PKG_VERSION)
|
||||
|
|
20
utils/fuse/patches/300-closefrom.patch
Normal file
20
utils/fuse/patches/300-closefrom.patch
Normal file
|
@ -0,0 +1,20 @@
|
|||
--- a/util/ulockmgr_server.c
|
||||
+++ b/util/ulockmgr_server.c
|
||||
@@ -124,7 +124,7 @@ static int receive_message(int sock, voi
|
||||
return res;
|
||||
}
|
||||
|
||||
-static int closefrom(int minfd)
|
||||
+static int closefrom2(int minfd)
|
||||
{
|
||||
DIR *dir = opendir("/proc/self/fd");
|
||||
if (dir) {
|
||||
@@ -384,7 +384,7 @@ int main(int argc, char *argv[])
|
||||
dup2(nullfd, 1);
|
||||
}
|
||||
close(3);
|
||||
- closefrom(5);
|
||||
+ closefrom2(5);
|
||||
while (1) {
|
||||
char c;
|
||||
int sock;
|
Loading…
Reference in a new issue