nss: update to 3.47.1 and fix xscale
also refresh patches
Signed-off-by: Lucian Cristian <lucian.cristian@gmail.com>
(cherry picked from commit 3bacf6e9cb
)
This commit is contained in:
parent
da51495aa8
commit
7e51bdee04
4 changed files with 12 additions and 8 deletions
|
@ -7,14 +7,14 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=nss
|
||||
PKG_VERSION:=3.47
|
||||
PKG_VERSION:=3.47.1
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:= \
|
||||
https://download.cdn.mozilla.net/pub/security/$(PKG_NAME)/releases/NSS_$(subst .,_,$(PKG_VERSION))_RTM/src \
|
||||
https://archive.mozilla.org/pub/security/$(PKG_NAME)/releases/NSS_$(subst .,_,$(PKG_VERSION))_RTM/src
|
||||
PKG_HASH:=6cd0c4438b616bdacc0b5f25ff1506b0d07ee97ea6c95d514c5487200a155fa7
|
||||
PKG_HASH:=1ae3d1cb1de345b258788f2ef6b10a460068034c3fd64f42427a183d8342a6fb
|
||||
|
||||
PKG_MAINTAINER:=Lucian Cristian <lucian.cristian@gmail.com>
|
||||
PKG_LICENCE:=MPL-2.0
|
||||
|
@ -58,6 +58,10 @@ ifeq ($(LBITS),64)
|
|||
export USE_64=1
|
||||
endif
|
||||
|
||||
ifeq ($(CONFIG_CPU_TYPE),"xscale")
|
||||
TARGET_CFLAGS+= -mfloat-abi=softfp
|
||||
endif
|
||||
|
||||
TARGET_LDFLAGS += -Wl,--gc-sections,--as-needed
|
||||
|
||||
export CROSS_COMPILE=1
|
||||
|
|
|
@ -10,7 +10,7 @@ Description: Adds auto-generated nss.pc and nss-config script, and
|
|||
diff -Naurp nss-3.28-orig/nss/Makefile nss-3.28/nss/Makefile
|
||||
--- nss-3.28-orig/nss/Makefile 2016-12-21 05:56:27.000000000 -0600
|
||||
+++ nss-3.28/nss/Makefile 2016-12-26 22:24:52.695146032 -0600
|
||||
@@ -46,7 +46,7 @@ include $(CORE_DEPTH)/coreconf/rules.mk
|
||||
@@ -47,7 +47,7 @@ include $(CORE_DEPTH)/coreconf/rules.mk
|
||||
# (7) Execute "local" rules. (OPTIONAL). #
|
||||
#######################################################################
|
||||
|
||||
|
|
|
@ -33,7 +33,7 @@
|
|||
ifeq (,$(filter-out WIN%,$(OS_TARGET)))
|
||||
--- a/nss/coreconf/Linux.mk 2019-04-01 10:08:59.129269177 +0300
|
||||
+++ b/nss/coreconf/Linux.mk 2019-04-01 10:09:15.557782574 +0300
|
||||
@@ -139,6 +139,7 @@
|
||||
@@ -143,6 +143,7 @@
|
||||
DEFINES += -D_REENTRANT
|
||||
endif
|
||||
|
||||
|
@ -41,7 +41,7 @@
|
|||
DSO_CFLAGS = -fPIC
|
||||
DSO_LDOPTS = -shared $(ARCHFLAG) -Wl,--gc-sections
|
||||
# The linker on Red Hat Linux 7.2 and RHEL 2.1 (GNU ld version 2.11.90.0.8)
|
||||
@@ -149,6 +150,7 @@
|
||||
@@ -153,6 +154,7 @@
|
||||
ZDEFS_FLAG = -Wl,-z,defs
|
||||
DSO_LDOPTS += $(if $(findstring 2.11.90.0.8,$(shell ld -v)),,$(ZDEFS_FLAG))
|
||||
LDFLAGS += $(ARCHFLAG) -z noexecstack
|
||||
|
@ -51,7 +51,7 @@
|
|||
# library directories.
|
||||
--- a/nss/coreconf/Linux.mk 2019-04-01 23:10:19.091912203 +0300
|
||||
+++ b/nss/coreconf/Linux.mk 2019-04-06 14:07:13.499169075 +0300
|
||||
@@ -140,7 +140,7 @@
|
||||
@@ -144,7 +144,7 @@
|
||||
endif
|
||||
|
||||
ifndef USE_NATIVE
|
||||
|
|
|
@ -12,7 +12,7 @@
|
|||
|
||||
--- a/nss/lib/sqlite/sqlite3.c
|
||||
+++ b/nss/lib/sqlite/sqlite3.c
|
||||
@@ -33761,7 +33761,8 @@ static int proxyConchLock(unixFile *pFile, uuid_t myHostID, int lockType){
|
||||
@@ -39626,7 +39626,8 @@ static int proxyConchLock(unixFile *pFile, uuid_t myHostID, int lockType){
|
||||
|
||||
if( nTries==1 ){
|
||||
conchModTime = buf.st_mtimespec;
|
||||
|
@ -22,7 +22,7 @@
|
|||
continue;
|
||||
}
|
||||
|
||||
@@ -33787,7 +33788,7 @@ static int proxyConchLock(unixFile *pFile, uuid_t myHostID, int lockType){
|
||||
@@ -39652,7 +39653,7 @@ static int proxyConchLock(unixFile *pFile, uuid_t myHostID, int lockType){
|
||||
/* don't break the lock on short read or a version mismatch */
|
||||
return SQLITE_BUSY;
|
||||
}
|
||||
|
|
Loading…
Reference in a new issue