Merge pull request #2893 from jow-/procps-ng-fix
procps-ng: fix build on systems without gettext development utilities
This commit is contained in:
commit
7d5e546887
2 changed files with 30 additions and 3 deletions
|
@ -21,6 +21,7 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
|
|||
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
PKG_INSTALL:=1
|
||||
PKG_FIXUP:=autoreconf
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
|
@ -39,9 +40,9 @@ define Package/procps-ng/Default
|
|||
MAINTAINER:=Gergely Kiss <mail.gery@gmail.com>
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
(cd $(PKG_BUILD_DIR); echo "$(PKG_VERSION)" > "$(PKG_BUILD_DIR)/.tarball-version"; ./autogen.sh );
|
||||
$(call Build/Configure/Default)
|
||||
define Build/Prepare
|
||||
$(call Build/Prepare/Default)
|
||||
echo "$(PKG_VERSION)" > "$(PKG_BUILD_DIR)/.tarball-version"
|
||||
endef
|
||||
|
||||
define Package/procps-ng
|
||||
|
|
26
utils/procps-ng/patches/100-no-tests-docs.patch
Normal file
26
utils/procps-ng/patches/100-no-tests-docs.patch
Normal file
|
@ -0,0 +1,26 @@
|
|||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -13,10 +13,7 @@ PACKAGE_VERSION = @PACKAGE_VERSION@
|
||||
|
||||
ACLOCAL_AMFLAGS = -I m4
|
||||
SUBDIRS = \
|
||||
- include \
|
||||
- man-po \
|
||||
- po \
|
||||
- testsuite
|
||||
+ include
|
||||
|
||||
AM_CFLAGS = -Iproc
|
||||
LDADD = ./proc/libprocps.la $(CYGWINFLAGS)
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -256,8 +256,5 @@ AC_CHECK_FUNCS([__fpending alarm atexit
|
||||
|
||||
AC_CONFIG_FILES([Makefile
|
||||
include/Makefile
|
||||
- man-po/Makefile
|
||||
- po/Makefile.in
|
||||
- proc/libprocps.pc
|
||||
- testsuite/Makefile])
|
||||
+ proc/libprocps.pc])
|
||||
AC_OUTPUT
|
Loading…
Reference in a new issue