rtorrent: Update to 0.9.7
Also switch to tarball. Should be faster. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
84197cc5d0
commit
7d5a934c97
3 changed files with 8 additions and 21 deletions
|
@ -8,15 +8,13 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=rtorrent
|
||||
PKG_VERSION:=0.9.6-git-1
|
||||
PKG_RELEASE=$(PKG_SOURCE_VERSION)
|
||||
PKG_VERSION:=0.9.7
|
||||
PKG_RELEASE:=1
|
||||
PKG_MAINTAINER:=Rosen Penev <rosenp@gmail.com>
|
||||
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_URL:=https://github.com/rakshasa/rtorrent.git
|
||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_SOURCE_VERSION:=62cb5a4605c0664bc522e0e0da9c72f09cf643a9
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
|
||||
PKG_MIRROR_HASH:=3c6834b12ebfa8d62618f6e9dbc06dfa593861fa0b435d2fd1bddb0e886fc77b
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://github.com/rakshasa/rtorrent/releases/download/v$(PKG_VERSION)
|
||||
PKG_HASH:=5d9842fe48c9582fbea2c7bf9f51412c1ccbba07d059b257039ad53b863fe8bb
|
||||
|
||||
PKG_LICENSE:=GPL-2.0
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
|
@ -36,7 +34,6 @@ define Package/rtorrent/Default
|
|||
TITLE:=BitTorrent client for ncurses
|
||||
URL:=http://libtorrent.rakshasa.no/
|
||||
DEPENDS:=+libcurl +libtorrent +libncursesw +libsigcxx +libpthread
|
||||
MAINTAINER:=Peter Wagner <tripolar@gmx.at>
|
||||
endef
|
||||
|
||||
define Package/rtorrent/Default/description
|
||||
|
|
|
@ -1,13 +1,3 @@
|
|||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -4,7 +4,6 @@ AC_DEFINE(API_VERSION, 9, api version)
|
||||
|
||||
AM_INIT_AUTOMAKE
|
||||
AC_CONFIG_HEADERS(config.h)
|
||||
-AM_PATH_CPPUNIT(1.9.6)
|
||||
|
||||
AC_PROG_CXX
|
||||
AC_PROG_LIBTOOL
|
||||
--- a/scripts/common.m4
|
||||
+++ b/scripts/common.m4
|
||||
@@ -153,7 +153,7 @@ dnl Need to fix this so that it uses t
|
||||
|
|
|
@ -6,6 +6,6 @@
|
|||
|
||||
- Canvas(int x = 0, int y = 0, int width = 0, int height = 0);
|
||||
+ Canvas(int x = 0, int y = 0, int width = 1, int height = 1);
|
||||
~Canvas() { delwin(m_window); }
|
||||
~Canvas() { if (!m_isDaemon) { delwin(m_window); } }
|
||||
|
||||
void refresh() { wnoutrefresh(m_window); }
|
||||
void refresh() { if (!m_isDaemon) { wnoutrefresh(m_window); } }
|
||||
|
|
Loading…
Reference in a new issue