strongswan: Update to 5.9.10
Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
This commit is contained in:
parent
1dfb13eaeb
commit
7cf43fabe2
2 changed files with 5 additions and 5 deletions
|
@ -8,12 +8,12 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=strongswan
|
PKG_NAME:=strongswan
|
||||||
PKG_VERSION:=5.9.9
|
PKG_VERSION:=5.9.10
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
PKG_SOURCE_URL:=https://download.strongswan.org/ https://download2.strongswan.org/
|
PKG_SOURCE_URL:=https://download.strongswan.org/ https://download2.strongswan.org/
|
||||||
PKG_HASH:=5e16580998834658c17cebfb31dd637e728669cf2fdd325460234a4643b8d81d
|
PKG_HASH:=3b72789e243c9fa6f0a01ccaf4f83766eba96a5e5b1e071d36e997572cf34654
|
||||||
PKG_LICENSE:=GPL-2.0-or-later
|
PKG_LICENSE:=GPL-2.0-or-later
|
||||||
PKG_MAINTAINER:=Philip Prindeville <philipp@redfish-solutions.com>, Noel Kuntze <noel.kuntze@thermi.consulting>
|
PKG_MAINTAINER:=Philip Prindeville <philipp@redfish-solutions.com>, Noel Kuntze <noel.kuntze@thermi.consulting>
|
||||||
PKG_CPE_ID:=cpe:/a:strongswan:strongswan
|
PKG_CPE_ID:=cpe:/a:strongswan:strongswan
|
||||||
|
|
|
@ -26,7 +26,7 @@ Subject: [PATCH 904/904] gmpdh: Plugin that implements gmp DH functions in an
|
||||||
ARG_DISBL_SET([curve25519], [disable Curve25519 Diffie-Hellman plugin.])
|
ARG_DISBL_SET([curve25519], [disable Curve25519 Diffie-Hellman plugin.])
|
||||||
ARG_DISBL_SET([hmac], [disable HMAC crypto implementation plugin.])
|
ARG_DISBL_SET([hmac], [disable HMAC crypto implementation plugin.])
|
||||||
ARG_DISBL_SET([kdf], [disable KDF (prf+) implementation plugin.])
|
ARG_DISBL_SET([kdf], [disable KDF (prf+) implementation plugin.])
|
||||||
@@ -1566,6 +1567,7 @@ ADD_PLUGIN([pkcs8], [s ch
|
@@ -1565,6 +1566,7 @@ ADD_PLUGIN([pkcs8], [s ch
|
||||||
ADD_PLUGIN([af-alg], [s charon pki scripts medsrv attest nm cmd aikgen])
|
ADD_PLUGIN([af-alg], [s charon pki scripts medsrv attest nm cmd aikgen])
|
||||||
ADD_PLUGIN([fips-prf], [s charon nm cmd])
|
ADD_PLUGIN([fips-prf], [s charon nm cmd])
|
||||||
ADD_PLUGIN([gmp], [s charon pki scripts manager medsrv attest nm cmd aikgen fuzz])
|
ADD_PLUGIN([gmp], [s charon pki scripts manager medsrv attest nm cmd aikgen fuzz])
|
||||||
|
@ -34,7 +34,7 @@ Subject: [PATCH 904/904] gmpdh: Plugin that implements gmp DH functions in an
|
||||||
ADD_PLUGIN([curve25519], [s charon pki scripts nm cmd])
|
ADD_PLUGIN([curve25519], [s charon pki scripts nm cmd])
|
||||||
ADD_PLUGIN([agent], [s charon nm cmd])
|
ADD_PLUGIN([agent], [s charon nm cmd])
|
||||||
ADD_PLUGIN([keychain], [s charon cmd])
|
ADD_PLUGIN([keychain], [s charon cmd])
|
||||||
@@ -1708,6 +1710,7 @@ AM_CONDITIONAL(USE_SHA3, test x$sha3 = x
|
@@ -1706,6 +1708,7 @@ AM_CONDITIONAL(USE_SHA3, test x$sha3 = x
|
||||||
AM_CONDITIONAL(USE_MGF1, test x$mgf1 = xtrue)
|
AM_CONDITIONAL(USE_MGF1, test x$mgf1 = xtrue)
|
||||||
AM_CONDITIONAL(USE_FIPS_PRF, test x$fips_prf = xtrue)
|
AM_CONDITIONAL(USE_FIPS_PRF, test x$fips_prf = xtrue)
|
||||||
AM_CONDITIONAL(USE_GMP, test x$gmp = xtrue)
|
AM_CONDITIONAL(USE_GMP, test x$gmp = xtrue)
|
||||||
|
@ -42,7 +42,7 @@ Subject: [PATCH 904/904] gmpdh: Plugin that implements gmp DH functions in an
|
||||||
AM_CONDITIONAL(USE_CURVE25519, test x$curve25519 = xtrue)
|
AM_CONDITIONAL(USE_CURVE25519, test x$curve25519 = xtrue)
|
||||||
AM_CONDITIONAL(USE_RDRAND, test x$rdrand = xtrue)
|
AM_CONDITIONAL(USE_RDRAND, test x$rdrand = xtrue)
|
||||||
AM_CONDITIONAL(USE_AESNI, test x$aesni = xtrue)
|
AM_CONDITIONAL(USE_AESNI, test x$aesni = xtrue)
|
||||||
@@ -1985,6 +1988,7 @@ AC_CONFIG_FILES([
|
@@ -1983,6 +1986,7 @@ AC_CONFIG_FILES([
|
||||||
src/libstrongswan/plugins/mgf1/Makefile
|
src/libstrongswan/plugins/mgf1/Makefile
|
||||||
src/libstrongswan/plugins/fips_prf/Makefile
|
src/libstrongswan/plugins/fips_prf/Makefile
|
||||||
src/libstrongswan/plugins/gmp/Makefile
|
src/libstrongswan/plugins/gmp/Makefile
|
||||||
|
|
Loading…
Reference in a new issue