ttyd: update to 1.7.3
also fixes linking issue that appeared after gcc 13 removed obsolete (merged) patch, ttyd now depends on libcap, added that as a dependency. remaining patch refreshed. release notes: https://github.com/tsl0922/ttyd/releases Signed-off-by: Oskari Rauta <oskari.rauta@gmail.com>
This commit is contained in:
parent
1abea58fec
commit
7cc8d25381
3 changed files with 6 additions and 20 deletions
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=ttyd
|
||||
PKG_VERSION:=1.6.3
|
||||
PKG_RELEASE:=3
|
||||
PKG_VERSION:=1.7.3
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/tsl0922/ttyd/tar.gz/$(PKG_VERSION)?
|
||||
PKG_HASH:=1116419527edfe73717b71407fb6e06f46098fc8a8e6b0bb778c4c75dc9f64b9
|
||||
PKG_HASH:=c9cf5eece52d27c5d728000f11315d36cb400c6948d1964a34a7eae74b454099
|
||||
|
||||
PKG_MAINTAINER:=Shuanglei Tao <tsl0922@gmail.com>
|
||||
PKG_LICENSE:=MIT
|
||||
|
@ -26,7 +26,7 @@ define Package/ttyd
|
|||
SECTION:=utils
|
||||
CATEGORY:=Utilities
|
||||
TITLE:=Command-line tool for sharing terminal over the web
|
||||
DEPENDS:=+libopenssl +libjson-c +libuv +zlib +libwebsockets-full
|
||||
DEPENDS:=+libcap +libopenssl +libjson-c +libuv +zlib +libwebsockets-full
|
||||
URL:=https://github.com/tsl0922/ttyd
|
||||
SUBMENU:=Terminal
|
||||
endef
|
||||
|
|
|
@ -1,14 +0,0 @@
|
|||
--- a/src/server.c
|
||||
+++ b/src/server.c
|
||||
@@ -509,9 +509,10 @@ int main(int argc, char **argv) {
|
||||
if (ssl) {
|
||||
info.ssl_cert_filepath = cert_path;
|
||||
info.ssl_private_key_filepath = key_path;
|
||||
- if (strlen(ca_path) > 0)
|
||||
+ if (strlen(ca_path) > 0) {
|
||||
info.ssl_ca_filepath = ca_path;
|
||||
info.options |= LWS_SERVER_OPTION_REQUIRE_VALID_OPENSSL_CLIENT_CERT;
|
||||
+ }
|
||||
#if LWS_LIBRARY_VERSION_MAJOR >= 2
|
||||
info.options |= LWS_SERVER_OPTION_REDIRECT_HTTP_TO_HTTPS;
|
||||
#endif
|
|
@ -8,7 +8,7 @@
|
|||
|
||||
#include "utils.h"
|
||||
|
||||
@@ -478,7 +479,8 @@ int main(int argc, char **argv) {
|
||||
@@ -509,7 +510,8 @@ int main(int argc, char **argv) {
|
||||
return -1;
|
||||
}
|
||||
|
||||
|
@ -16,5 +16,5 @@
|
|||
+ openlog("ttyd", LOG_NDELAY | LOG_PID, LOG_DAEMON);
|
||||
+ lws_set_log_level(debug_level, lwsl_emit_syslog);
|
||||
|
||||
#if LWS_LIBRARY_VERSION_MAJOR >= 2
|
||||
char server_hdr[128] = "";
|
||||
sprintf(server_hdr, "ttyd/%s (libwebsockets/%s)", TTYD_VERSION, LWS_LIBRARY_VERSION);
|
||||
|
|
Loading…
Reference in a new issue