python: reduce size of patch 130
Try to reduce the amount of change in this patch, since it removes a lot of stuff, when we could just 'ifdef' that stuff out, with 2 lines. The buildroot project does something similar like this: http://git.buildroot.net/buildroot/tree/package/python/005-pyc-pyo-conditional.patch Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
This commit is contained in:
parent
022b27604b
commit
7c4dac5118
2 changed files with 20 additions and 37 deletions
20
lang/python/patches/130-do-not-compile-tests-at-build.patch
Normal file
20
lang/python/patches/130-do-not-compile-tests-at-build.patch
Normal file
|
@ -0,0 +1,20 @@
|
||||||
|
diff --git a/Makefile.pre.in b/Makefile.pre.in
|
||||||
|
index 7f4ec2f..e270bf2 100644
|
||||||
|
--- a/Makefile.pre.in
|
||||||
|
+++ b/Makefile.pre.in
|
||||||
|
@@ -1038,6 +1038,7 @@ libinstall: build_all $(srcdir)/Lib/$(PLATDIR) $(srcdir)/Modules/xxmodule.c
|
||||||
|
done; \
|
||||||
|
done
|
||||||
|
$(INSTALL_DATA) $(srcdir)/LICENSE $(DESTDIR)$(LIBDEST)/LICENSE.txt
|
||||||
|
+ifeq (@COMPILE_ALL_TESTS@,yes)
|
||||||
|
if test -d $(DESTDIR)$(LIBDEST)/distutils/tests; then \
|
||||||
|
$(INSTALL_DATA) $(srcdir)/Modules/xxmodule.c \
|
||||||
|
$(DESTDIR)$(LIBDEST)/distutils/tests ; \
|
||||||
|
@@ -1064,6 +1065,7 @@ libinstall: build_all $(srcdir)/Lib/$(PLATDIR) $(srcdir)/Modules/xxmodule.c
|
||||||
|
$(PYTHON_FOR_BUILD) -m lib2to3.pgen2.driver $(DESTDIR)$(LIBDEST)/lib2to3/Grammar.txt
|
||||||
|
-PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
|
||||||
|
$(PYTHON_FOR_BUILD) -m lib2to3.pgen2.driver $(DESTDIR)$(LIBDEST)/lib2to3/PatternGrammar.txt
|
||||||
|
+endif
|
||||||
|
|
||||||
|
# Create the PLATDIR source directory, if one wasn't distributed..
|
||||||
|
$(srcdir)/Lib/$(PLATDIR):
|
|
@ -1,37 +0,0 @@
|
||||||
diff --git a/Makefile.pre.in b/Makefile.pre.in
|
|
||||||
index bcd83bf..c4dcc6d 100644
|
|
||||||
--- a/Makefile.pre.in
|
|
||||||
+++ b/Makefile.pre.in
|
|
||||||
@@ -1005,32 +1005,6 @@ libinstall: build_all $(srcdir)/Lib/$(PLATDIR) $(srcdir)/Modules/xxmodule.c
|
|
||||||
done; \
|
|
||||||
done
|
|
||||||
$(INSTALL_DATA) $(srcdir)/LICENSE $(DESTDIR)$(LIBDEST)/LICENSE.txt
|
|
||||||
- if test -d $(DESTDIR)$(LIBDEST)/distutils/tests; then \
|
|
||||||
- $(INSTALL_DATA) $(srcdir)/Modules/xxmodule.c \
|
|
||||||
- $(DESTDIR)$(LIBDEST)/distutils/tests ; \
|
|
||||||
- fi
|
|
||||||
- PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
|
|
||||||
- $(PYTHON_FOR_BUILD) -Wi -tt $(DESTDIR)$(LIBDEST)/compileall.py \
|
|
||||||
- -d $(LIBDEST) -f \
|
|
||||||
- -x 'bad_coding|badsyntax|site-packages|lib2to3/tests/data' \
|
|
||||||
- $(DESTDIR)$(LIBDEST)
|
|
||||||
- PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
|
|
||||||
- $(PYTHON_FOR_BUILD) -Wi -tt -O $(DESTDIR)$(LIBDEST)/compileall.py \
|
|
||||||
- -d $(LIBDEST) -f \
|
|
||||||
- -x 'bad_coding|badsyntax|site-packages|lib2to3/tests/data' \
|
|
||||||
- $(DESTDIR)$(LIBDEST)
|
|
||||||
- -PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
|
|
||||||
- $(PYTHON_FOR_BUILD) -Wi -t $(DESTDIR)$(LIBDEST)/compileall.py \
|
|
||||||
- -d $(LIBDEST)/site-packages -f \
|
|
||||||
- -x badsyntax $(DESTDIR)$(LIBDEST)/site-packages
|
|
||||||
- -PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
|
|
||||||
- $(PYTHON_FOR_BUILD) -Wi -t -O $(DESTDIR)$(LIBDEST)/compileall.py \
|
|
||||||
- -d $(LIBDEST)/site-packages -f \
|
|
||||||
- -x badsyntax $(DESTDIR)$(LIBDEST)/site-packages
|
|
||||||
- -PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
|
|
||||||
- $(PYTHON_FOR_BUILD) -m lib2to3.pgen2.driver $(DESTDIR)$(LIBDEST)/lib2to3/Grammar.txt
|
|
||||||
- -PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
|
|
||||||
- $(PYTHON_FOR_BUILD) -m lib2to3.pgen2.driver $(DESTDIR)$(LIBDEST)/lib2to3/PatternGrammar.txt
|
|
||||||
|
|
||||||
# Create the PLATDIR source directory, if one wasn't distributed..
|
|
||||||
$(srcdir)/Lib/$(PLATDIR):
|
|
Loading…
Reference in a new issue