Merge pull request from neheb/nbm

svox: fix compilation with newer musl
This commit is contained in:
Rosen Penev 2020-03-20 16:17:48 -07:00 committed by GitHub
commit 7bf1d3ffb5
No known key found for this signature in database
GPG key ID: 4AEE18F83AFDEB23
2 changed files with 3 additions and 2 deletions

View file

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=svox PKG_NAME:=svox
PKG_VERSION:=1.0+git20130326 PKG_VERSION:=1.0+git20130326
PKG_RELEASE:=2 PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/non-free/s/svox PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/non-free/s/svox

View file

@ -41,7 +41,7 @@ new file mode 100644
index 0000000..0c035a7 index 0000000..0c035a7
--- /dev/null --- /dev/null
+++ b/pico/bin/pico2wave.c +++ b/pico/bin/pico2wave.c
@@ -0,0 +1,341 @@ @@ -0,0 +1,342 @@
+/* pico2wave.c +/* pico2wave.c
+ +
+ * Copyright (C) 2009 Mathieu Parent <math.parent@gmail.com> + * Copyright (C) 2009 Mathieu Parent <math.parent@gmail.com>
@ -65,6 +65,7 @@ index 0000000..0c035a7
+ +
+#include <popt.h> +#include <popt.h>
+#include <stdio.h> +#include <stdio.h>
+#include <stdint.h>
+#include <stdlib.h> +#include <stdlib.h>
+#include <string.h> +#include <string.h>
+ +