Merge pull request #5079 from wigyori/for-15.05-crtmpd

CC: multimedia/crtmpserver: fix build
This commit is contained in:
Thomas Heil 2017-11-08 00:10:17 +01:00 committed by GitHub
commit 7b9e2e0208
No known key found for this signature in database
GPG key ID: 4AEE18F83AFDEB23
8 changed files with 29 additions and 41 deletions

View file

@ -8,19 +8,19 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=crtmpserver
PKG_REV:=811
PKG_VERSION:=r$(PKG_REV)
PKG_RELEASE:=1
PKG_REV:=b6fdcdb
PKG_VERSION:=2012-07-18+git-$(PKG_REV)
PKG_RELEASE:=2
PKG_BUILD_PARALLEL:=2
PKG_MAINTAINER:=Thomas Heil <heil@terminal-consulting.de>
PKG_LICENSE:=GPL-3.0
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=--username=anonymous --password= https://svn.rtmpd.com/crtmpserver/branches/1.0
PKG_SOURCE_URL:=https://github.com/j0sh/crtmpserver.git
PKG_SOURCE_SUBDIR:=crtmpserver-$(PKG_VERSION)
PKG_SOURCE_VERSION:=$(PKG_REV)
PKG_SOURCE_PROTO:=svn
PKG_SOURCE_PROTO:=git
include $(INCLUDE_DIR)/package.mk
@ -66,6 +66,9 @@ define Build/Configure
-e 's,^OPTIMIZATIONS[[:space:]]*=.*,OPTIMIZATIONS=-O2,' \
-e 's,^SSL_BASE[[:space:]]*=.*,SSL_BASE=$(STAGING_DIR)/usr,' \
linux-openwrt-uclibc.mk)
(cd $(PKG_BUILD_DIR)/sources/common/include/; \
echo '#define CRTMPSERVER_VERSION_RELEASE_NUMBER "$(PKG_VERSION)\n"' > version.h; \
echo '#define CRTMPSERVER_VERSION_CODE_NAME "Git\n"' >> version.h)
endef
define Build/Compile

View file

@ -1,6 +1,6 @@
--- a/builders/make/compile.mk
+++ b/builders/make/compile.mk
@@ -67,7 +67,7 @@ TINYXML_OBJS = $(TINYXML_SRCS:.cpp=.tiny
@@ -72,7 +72,7 @@ TINYXML_OBJS = $(TINYXML_SRCS:.cpp=.tiny
#common
COMMON_INCLUDE=$(LUA_INCLUDE) $(TINYXML_INCLUDE) $(SSL_INCLUDE) -I$(PROJECT_BASE_PATH)/sources/common/include

View file

@ -23,7 +23,7 @@
-- It is optional. If not specified, it will be defaulted to:
-- <rootDirectory>/<name>/mediaFolder
- -- mediaFolder="/some/directory/where/media/files/are/stored"
+ mediaFolder="/usr/share/crtmpserver/appselector",
+ mediaFolder="/media",
-- the application will also be known by that names. It is optional
--aliases=
--{
@ -41,16 +41,7 @@
port=8080,
protocol="inboundRtmpt"
},
@@ -105,7 +98,7 @@ configuration=
description="FLV Playback Sample",
name="flvplayback",
protocol="dynamiclinklibrary",
- mediaFolder="/Volumes/android/backup/media/",
+ mediaFolder="/media/",
aliases=
{
"simpleLive",
@@ -183,6 +176,7 @@ configuration=
@@ -184,6 +177,7 @@ configuration=
name="samplefactory",
description="asdsadasdsa",
protocol="dynamiclinklibrary",

View file

@ -1,7 +1,5 @@
Index: crtmpserver-r726/builders/make/linux.mk
===================================================================
--- crtmpserver-r726.orig/builders/make/linux.mk
+++ crtmpserver-r726/builders/make/linux.mk
--- a/builders/make/linux.mk
+++ b/builders/make/linux.mk
@@ -38,7 +38,7 @@ dynamic_exec_flags = $(FPIC) $(OPTIMIZAT
PLATFORM_DEFINES = \
-DLINUX \

View file

@ -1,22 +1,6 @@
--- a/builders/make/compile.mk
+++ b/builders/make/compile.mk
@@ -43,17 +43,22 @@ FEATURES_DEFINES = \
-DHAS_PROTOCOL_RTP \
-DHAS_PROTOCOL_TS \
-DHAS_PROTOCOL_VAR \
+ -DHAS_PROTOCOL_CLI \
+ -DHAS_PROTOCOL_HLS \
+ -DHAS_PROTOCOL_RAWHTTPSTREAM \
-DHAS_LUA \
-DHAS_MEDIA_MP3 \
-DHAS_MEDIA_MP4 \
- -DHAS_MEDIA_FLV
+ -DHAS_MEDIA_FLV \
+ -DHAS_SYSLOG
+
DEFINES = $(PLATFORM_DEFINES) $(FEATURES_DEFINES)
@@ -58,7 +58,7 @@ DEFINES = $(PLATFORM_DEFINES) $(FEATURES
#library paths
SSL_INCLUDE=-I$(SSL_BASE)/include
@ -25,7 +9,7 @@
#lua
LUA_INCLUDE=-I$(PROJECT_BASE_PATH)/3rdparty/lua-dev
@@ -67,25 +72,25 @@ TINYXML_OBJS = $(TINYXML_SRCS:.cpp=.tiny
@@ -72,25 +72,25 @@ TINYXML_OBJS = $(TINYXML_SRCS:.cpp=.tiny
#common
COMMON_INCLUDE=$(LUA_INCLUDE) $(TINYXML_INCLUDE) $(SSL_INCLUDE) -I$(PROJECT_BASE_PATH)/sources/common/include

View file

@ -23,4 +23,4 @@
+
#include "utils/logging/fileloglocation.h"
#include "utils/lua/luautils.h"
#include "utils/misc/file.h"

View file

@ -5,6 +5,6 @@
#include <iostream>
#include <sstream>
+#include "lstate.h"
using namespace std;
// Help out windows:
#if defined( _DEBUG ) && !defined( DEBUG )

View file

@ -0,0 +1,12 @@
--- a/builders/make/apps.mk
+++ b/builders/make/apps.mk
@@ -110,6 +110,6 @@ vptests: thelib $(VPTESTS_OBJS)
%.vptests.o: %.cpp
$(CXXCOMPILER) $(COMPILE_FLAGS) $(DEFINES) $(VPTESTS_INCLUDE) -c $< -o $@
-ALL_APPS_OBJS= $(ADMIN_OBJS) $(APPLESTREAMINGCLIENT_OBJS) $(APPSELECTOR_OBJS) $(FLVPLAYBACK_OBJS) $(PROXYPUBLISH_OBJS) $(SAMPLEFACTORY_OBJS) $(STRESSTEST_OBJS) $(VPTESTS_OBJS)
-ACTIVE_APPS= -DHAS_APP_ADMIN -DHAS_APP_APPLESTREAMINGCLIENT -DHAS_APP_APPSELECTOR -DHAS_APP_FLVPLAYBACK -DHAS_APP_PROXYPUBLISH -DHAS_APP_SAMPLEFACTORY -DHAS_APP_STRESSTEST -DHAS_APP_VPTESTS
-applications: thelib admin applestreamingclient appselector flvplayback proxypublish samplefactory stresstest vptests
+ALL_APPS_OBJS= $(ADMIN_OBJS) $(APPSELECTOR_OBJS) $(FLVPLAYBACK_OBJS) $(PROXYPUBLISH_OBJS) $(SAMPLEFACTORY_OBJS) $(STRESSTEST_OBJS) $(VPTESTS_OBJS)
+ACTIVE_APPS= -DHAS_APP_ADMIN -DHAS_APP_APPSELECTOR -DHAS_APP_FLVPLAYBACK -DHAS_APP_PROXYPUBLISH -DHAS_APP_SAMPLEFACTORY -DHAS_APP_STRESSTEST -DHAS_APP_VPTESTS
+applications: thelib admin appselector flvplayback proxypublish samplefactory stresstest vptests