openssh: update to 7.3p1
Signed-off-by: Peter Wagner <tripolar@gmx.at>
This commit is contained in:
parent
39f0b6f067
commit
7ad9eb6703
2 changed files with 2 additions and 15 deletions
|
@ -8,13 +8,13 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=openssh
|
||||
PKG_VERSION:=7.2p2
|
||||
PKG_VERSION:=7.3p1
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/ \
|
||||
http://ftp.belnet.be/pub/OpenBSD/OpenSSH/portable/
|
||||
PKG_MD5SUM:=13009a9156510d8f27e752659075cced
|
||||
PKG_MD5SUM:=dfadd9f035d38ce5d58a3bf130b86d08
|
||||
|
||||
PKG_LICENSE:=BSD ISC
|
||||
PKG_LICENSE_FILES:=LICENCE
|
||||
|
|
|
@ -1,13 +0,0 @@
|
|||
--- a/cipher.c
|
||||
+++ b/cipher.c
|
||||
@@ -88,8 +88,10 @@ static const struct sshcipher ciphers[]
|
||||
{ "3des-cbc", SSH_CIPHER_SSH2, 8, 24, 0, 0, 0, 1, EVP_des_ede3_cbc },
|
||||
{ "blowfish-cbc",
|
||||
SSH_CIPHER_SSH2, 8, 16, 0, 0, 0, 1, EVP_bf_cbc },
|
||||
+#ifndef OPENSSL_NO_CAST
|
||||
{ "cast128-cbc",
|
||||
SSH_CIPHER_SSH2, 8, 16, 0, 0, 0, 1, EVP_cast5_cbc },
|
||||
+#endif
|
||||
{ "arcfour", SSH_CIPHER_SSH2, 8, 16, 0, 0, 0, 0, EVP_rc4 },
|
||||
{ "arcfour128", SSH_CIPHER_SSH2, 8, 16, 0, 0, 1536, 0, EVP_rc4 },
|
||||
{ "arcfour256", SSH_CIPHER_SSH2, 8, 32, 0, 0, 1536, 0, EVP_rc4 },
|
Loading…
Reference in a new issue