fbzmq: Update to 2019.10.07.00
Added patch that adds libfolly boost dependencies. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
dbfea329d3
commit
7a5326dd29
3 changed files with 24 additions and 39 deletions
|
@ -1,19 +1,17 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=fbzmq
|
||||
PKG_VERSION:=2019.06.10.00
|
||||
PKG_RELEASE:=4
|
||||
PKG_VERSION:=2019.10.07.00
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/facebook/fbzmq/tar.gz/v$(PKG_VERSION)?
|
||||
PKG_HASH:=9bb9b2bd42951fa3458b5d6d25f3364c14a7efa3b78bef68a6c00ee6fcba5813
|
||||
PKG_HASH:=41b6c671dd1cd16eeffa94f146c8a6841c8a05e0517d8affc96dde8324af11af
|
||||
|
||||
PKG_MAINTAINER:=Amol Bhave <ambhave@fb.com>
|
||||
PKG_LICENSE:=MIT
|
||||
PKG_LICENSE_FILES:=LICENSE
|
||||
|
||||
CMAKE_SOURCE_SUBDIR:=fbzmq
|
||||
PKG_BUILD_DEPENDS:=fbthrift
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
CMAKE_INSTALL:=1
|
||||
|
||||
|
@ -25,7 +23,7 @@ define Package/fbzmq
|
|||
CATEGORY:=Libraries
|
||||
TITLE:=Facebook ZeroMQ wrappers.
|
||||
URL:=https://github.com/facebook/fbzmq
|
||||
DEPENDS:=+libfolly +libzmq +libsigar
|
||||
DEPENDS:=+libfolly +libzmq +libsigar +fbthrift
|
||||
endef
|
||||
|
||||
define Package/fbzmq/description
|
||||
|
@ -34,12 +32,17 @@ endef
|
|||
|
||||
CMAKE_OPTIONS += \
|
||||
-DCMAKE_POSITION_INDEPENDENT_CODE=ON \
|
||||
-DBUILD_SHARED_LIBS=ON \
|
||||
-DBUILD_TESTS=OFF \
|
||||
-DTHRIFT1="$(STAGING_DIR_HOSTPKG)/bin/thrift1" \
|
||||
-DTHRIFT_COMPILER_INCLUDE="$(STAGING_DIR_HOSTPKG)/include/"
|
||||
-DFBTHRIFT_COMPILER="$(STAGING_DIR_HOSTPKG)/bin/thrift1"
|
||||
|
||||
TARGET_CXXFLAGS += -faligned-new
|
||||
TARGET_CXXFLAGS += -ffunction-sections -fdata-sections -flto
|
||||
TARGET_LDFLAGS += -Wl,--gc-sections,--as-needed
|
||||
|
||||
define Package/fbzmq/install
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libfbzmq.so* $(1)/usr/lib/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,fbzmq))
|
||||
|
|
13
libs/fbzmq/patches/010-fbthrift.patch
Normal file
13
libs/fbzmq/patches/010-fbthrift.patch
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -34,6 +34,10 @@ find_package(Threads REQUIRED)
|
||||
find_package(Boost 1.67.0 MODULE
|
||||
COMPONENTS
|
||||
context
|
||||
+ filesystem
|
||||
+ program_options
|
||||
+ regex
|
||||
+ system
|
||||
REQUIRED
|
||||
)
|
||||
|
|
@ -1,31 +0,0 @@
|
|||
--- a/fbzmq/zmq/Message.cpp
|
||||
+++ b/fbzmq/zmq/Message.cpp
|
||||
@@ -35,7 +35,7 @@ Message::allocate(size_t size) noexcept {
|
||||
if (rc != 0) {
|
||||
return folly::makeUnexpected(Error());
|
||||
}
|
||||
- return std::move(msg);
|
||||
+ return msg;
|
||||
}
|
||||
|
||||
folly::Expected<Message, Error>
|
||||
@@ -58,7 +58,7 @@ Message::wrapBuffer(std::unique_ptr<folly::IOBuf> buf) noexcept {
|
||||
delete ptr;
|
||||
return folly::makeUnexpected(Error());
|
||||
}
|
||||
- return std::move(msg);
|
||||
+ return msg;
|
||||
}
|
||||
|
||||
Message&
|
||||
--- a/fbzmq/zmq/Socket.cpp
|
||||
+++ b/fbzmq/zmq/Socket.cpp
|
||||
@@ -449,7 +449,7 @@ SocketImpl::recv(int flags) const noexcept {
|
||||
while (true) {
|
||||
const int n = zmq_msg_recv(&(msg.msg_), ptr_, flags);
|
||||
if (n >= 0) {
|
||||
- return std::move(msg);
|
||||
+ return msg;
|
||||
}
|
||||
|
||||
const int err = zmq_errno();
|
Loading…
Reference in a new issue