python-pynacl: fix build with new libsodium patch
Fixes https://github.com/openwrt/packages/issues/13016
Patch [1] broke compilation for python-pynacl.
The fix is to patch PyNaCl to consider that
PYNACL_HAS_CRYPTO_SCALARMULT_ED25519 is always available.
[1] 3ef28a4ab0
Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
This commit is contained in:
parent
7f620401af
commit
79dfbd8016
2 changed files with 14 additions and 1 deletions
|
@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=python-pynacl
|
||||
PKG_VERSION:=1.4.0
|
||||
PKG_RELEASE:=3
|
||||
PKG_RELEASE:=4
|
||||
|
||||
PYPI_NAME:=PyNaCl
|
||||
PKG_HASH:=54e9a2c849c742006516ad56a88f5c74bf2ce92c9f67435187c3c5953b346505
|
||||
|
|
|
@ -0,0 +1,13 @@
|
|||
diff --git a/src/bindings/minimal/crypto_scalarmult.h b/src/bindings/minimal/crypto_scalarmult.h
|
||||
index 06ca1ef..9bc3d8e 100644
|
||||
--- a/src/bindings/minimal/crypto_scalarmult.h
|
||||
+++ b/src/bindings/minimal/crypto_scalarmult.h
|
||||
@@ -13,7 +13,7 @@
|
||||
* limitations under the License.
|
||||
*/
|
||||
|
||||
-#ifdef SODIUM_LIBRARY_MINIMAL
|
||||
+#if 0
|
||||
static const int PYNACL_HAS_CRYPTO_SCALARMULT_ED25519 = 0;
|
||||
|
||||
size_t (*crypto_scalarmult_ed25519_bytes)() = NULL;
|
Loading…
Reference in a new issue