lxc: bump to 2.1.1
This is the first bugfix release for LXC 2.1. Full list of changes can be found here: https://linuxcontainers.org/lxc/news/ Signed-off-by: Marko Ratkaj <marko.ratkaj@sartura.hr>
This commit is contained in:
parent
4c26e09cb7
commit
792c5713ad
4 changed files with 4 additions and 14 deletions
|
@ -14,6 +14,7 @@ config LXC_KERNEL_OPTIONS
|
||||||
select KERNEL_MEMCG
|
select KERNEL_MEMCG
|
||||||
select KERNEL_MEMCG_KMEM
|
select KERNEL_MEMCG_KMEM
|
||||||
select KERNEL_CPUSETS
|
select KERNEL_CPUSETS
|
||||||
|
select PACKAGE_kmod-ikconfig
|
||||||
help
|
help
|
||||||
Select needed kernel options for LXC related utilities. Options
|
Select needed kernel options for LXC related utilities. Options
|
||||||
include cgroups, namespaces and other miscellaneous options. These
|
include cgroups, namespaces and other miscellaneous options. These
|
||||||
|
|
|
@ -8,7 +8,7 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=lxc
|
PKG_NAME:=lxc
|
||||||
PKG_VERSION:=2.1.0
|
PKG_VERSION:=2.1.1
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_LICENSE:=LGPL-2.1+ BSD-2-Clause GPL-2.0
|
PKG_LICENSE:=LGPL-2.1+ BSD-2-Clause GPL-2.0
|
||||||
|
@ -16,7 +16,7 @@ PKG_MAINTAINER:=Marko Ratkaj <marko.ratkaj@sartura.hr>
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=https://linuxcontainers.org/downloads/lxc/
|
PKG_SOURCE_URL:=https://linuxcontainers.org/downloads/lxc/
|
||||||
PKG_HASH:=394407305a409eb1f95fe06e7718acfe89b1d5df267b0c6aafb1d714e2038de2
|
PKG_HASH:=68663a67450a8d6734e137eac54cc7077209fb15c456eec401a2c26e6386eff6
|
||||||
|
|
||||||
PKG_BUILD_DEPENDS:=lua
|
PKG_BUILD_DEPENDS:=lua
|
||||||
PKG_BUILD_PARALLEL:=1
|
PKG_BUILD_PARALLEL:=1
|
||||||
|
|
|
@ -1,11 +0,0 @@
|
||||||
--- a/src/lxc/storage/overlay.c
|
|
||||||
+++ b/src/lxc/storage/overlay.c
|
|
||||||
@@ -747,7 +747,7 @@ int ovl_mkdir(const struct mntent *mntent, const struct lxc_rootfs *rootfs,
|
|
||||||
char lxcpath[MAXPATHLEN];
|
|
||||||
char **opts;
|
|
||||||
int ret;
|
|
||||||
- size_t arrlen, dirlen, i, len, rootfslen;
|
|
||||||
+ size_t arrlen, i, len, rootfslen, dirlen = 0;
|
|
||||||
int fret = -1;
|
|
||||||
char *rootfs_dir = NULL, *rootfs_path = NULL, *upperdir = NULL,
|
|
||||||
*workdir = NULL;
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/src/lxc/confile_utils.c
|
--- a/src/lxc/confile_utils.c
|
||||||
+++ b/src/lxc/confile_utils.c
|
+++ b/src/lxc/confile_utils.c
|
||||||
@@ -690,7 +690,7 @@ bool parse_limit_value(const char **value, unsigned long *res)
|
@@ -677,7 +677,7 @@
|
||||||
char *endptr = NULL;
|
char *endptr = NULL;
|
||||||
|
|
||||||
if (strncmp(*value, "unlimited", sizeof("unlimited") - 1) == 0) {
|
if (strncmp(*value, "unlimited", sizeof("unlimited") - 1) == 0) {
|
||||||
|
|
Loading…
Reference in a new issue