python: bump to version 2.7.14
Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
This commit is contained in:
parent
e2513afdaa
commit
79276ef7b7
3 changed files with 9 additions and 5 deletions
|
@ -12,11 +12,11 @@ include ./files/python-version.mk
|
|||
|
||||
PKG_NAME:=python
|
||||
PKG_VERSION:=$(PYTHON_VERSION).$(PYTHON_VERSION_MICRO)
|
||||
PKG_RELEASE:=7
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=Python-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=https://www.python.org/ftp/python/$(PKG_VERSION)
|
||||
PKG_HASH:=35d543986882f78261f97787fd3e06274bfa6df29fac9b4a94f73930ff98f731
|
||||
PKG_HASH:=71ffb26e09e78650e424929b2b457b9c912ac216576e6bd9e7d204ed03296a66
|
||||
|
||||
PKG_LICENSE:=PSF
|
||||
PKG_LICENSE_FILES:=LICENSE Modules/_ctypes/libffi_msvc/LICENSE Modules/_ctypes/darwin/LICENSE Modules/_ctypes/libffi/LICENSE Modules/_ctypes/libffi_osx/LICENSE Tools/pybench/LICENSE
|
||||
|
@ -296,6 +296,10 @@ HOST_CONFIGURE_ARGS+= \
|
|||
--with-ensurepip=install \
|
||||
CONFIG_SITE=
|
||||
|
||||
define Host/Compile
|
||||
$(call Host/Compile/Default,python Parser/pgen sharedmods)
|
||||
endef
|
||||
|
||||
define Host/Install
|
||||
$(call Build/InstallMkFiles)
|
||||
$(MAKE) -C $(HOST_BUILD_DIR) install
|
||||
|
|
|
@ -6,7 +6,7 @@
|
|||
#
|
||||
|
||||
PYTHON_VERSION:=2.7
|
||||
PYTHON_VERSION_MICRO:=13
|
||||
PYTHON_VERSION_MICRO:=14
|
||||
|
||||
PYTHON_SETUPTOOLS_VERSION:=28.8.0
|
||||
PYTHON_PIP_VERSION:=9.0.1
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/Makefile.pre.in
|
||||
+++ b/Makefile.pre.in
|
||||
@@ -1116,6 +1116,7 @@ libinstall: build_all $(srcdir)/Lib/$(PL
|
||||
@@ -1110,6 +1110,7 @@ libinstall: build_all $(srcdir)/Lib/$(PL
|
||||
done; \
|
||||
done
|
||||
$(INSTALL_DATA) $(srcdir)/LICENSE $(DESTDIR)$(LIBDEST)/LICENSE.txt
|
||||
|
@ -8,7 +8,7 @@
|
|||
if test -d $(DESTDIR)$(LIBDEST)/distutils/tests; then \
|
||||
$(INSTALL_DATA) $(srcdir)/Modules/xxmodule.c \
|
||||
$(DESTDIR)$(LIBDEST)/distutils/tests ; \
|
||||
@@ -1142,6 +1143,7 @@ libinstall: build_all $(srcdir)/Lib/$(PL
|
||||
@@ -1136,6 +1137,7 @@ libinstall: build_all $(srcdir)/Lib/$(PL
|
||||
$(PYTHON_FOR_BUILD) -m lib2to3.pgen2.driver $(DESTDIR)$(LIBDEST)/lib2to3/Grammar.txt
|
||||
-PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
|
||||
$(PYTHON_FOR_BUILD) -m lib2to3.pgen2.driver $(DESTDIR)$(LIBDEST)/lib2to3/PatternGrammar.txt
|
||||
|
|
Loading…
Reference in a new issue