squid: bump to release 5.7
This is the latest version and brings compatibility with OpenSSL 3.0. Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
This commit is contained in:
parent
94b06478ed
commit
78dcc29e47
4 changed files with 6 additions and 28 deletions
|
@ -8,13 +8,13 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=squid
|
||||
PKG_VERSION:=4.17
|
||||
PKG_RELEASE:=$(AUTORELEASE)
|
||||
PKG_VERSION:=5.7
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=http://www2.pl.squid-cache.org/Versions/v4/ \
|
||||
http://www.squid-cache.org/Versions/v4/
|
||||
PKG_HASH:=cb928ac08c7c86b151b1c8f827abe1a84d83181a2a86e0d512286163e1e31418
|
||||
PKG_SOURCE_URL:=http://www2.pl.squid-cache.org/Versions/v5/ \
|
||||
http://www.squid-cache.org/Versions/v5/
|
||||
PKG_HASH:=6b0753aaba4c9c4efd333e67124caecf7ad6cc2d38581f19d2f0321f5b7ecd81
|
||||
|
||||
PKG_MAINTAINER:=Marko Ratkaj <markoratkaj@gmail.com>
|
||||
PKG_LICENSE:=GPL-2.0-or-later
|
||||
|
|
|
@ -1,12 +0,0 @@
|
|||
--- a/src/tools.cc
|
||||
+++ b/src/tools.cc
|
||||
@@ -582,7 +582,8 @@ enter_suid(void)
|
||||
}
|
||||
#else
|
||||
|
||||
- setuid(0);
|
||||
+ if (setuid(0) < 0)
|
||||
+ debugs(50, 1, "no_suid: setuid (0)");
|
||||
#endif
|
||||
#if HAVE_PRCTL && defined(PR_SET_DUMPABLE)
|
||||
/* Set Linux DUMPABLE flag */
|
|
@ -1,6 +1,6 @@
|
|||
--- a/src/Makefile.am
|
||||
+++ b/src/Makefile.am
|
||||
@@ -765,7 +765,7 @@ cache_cf.o: cf_parser.cci
|
||||
@@ -761,7 +761,7 @@ cache_cf.o: cf_parser.cci
|
||||
|
||||
# cf_gen builds the configuration files.
|
||||
cf_gen$(EXEEXT): $(cf_gen_SOURCES) $(cf_gen_DEPENDENCIES) cf_gen_defines.cci
|
|
@ -1,10 +0,0 @@
|
|||
--- a/src/esi/Libxml2Parser.cc
|
||||
+++ b/src/esi/Libxml2Parser.cc
|
||||
@@ -91,7 +91,6 @@ ESILibxml2Parser::ESILibxml2Parser(ESIPa
|
||||
|
||||
/* TODO: grab the document encoding from the headers */
|
||||
parser = xmlCreatePushParserCtxt(&sax, static_cast<void *>(this), NULL, 0, NULL);
|
||||
- xmlSetFeature(parser, "substitute entities", 0);
|
||||
|
||||
if (entity_doc == NULL)
|
||||
entity_doc = htmlNewDoc(NULL, NULL);
|
Loading…
Reference in a new issue