pulseaudio: update to 13.0
Converted to use meson for compilation speed. Removed libwrap dependency. Upstream no longer supports it. Removed intltool and glib2 host dependencies. They seem to be no longer needed. Removed upstream patch. Minor cleanups. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
0551a5b030
commit
78d84d4c9c
2 changed files with 50 additions and 174 deletions
|
@ -8,34 +8,33 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=pulseaudio
|
||||
PKG_VERSION:=12.2
|
||||
PKG_RELEASE:=4
|
||||
PKG_VERSION:=13.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=https://freedesktop.org/software/pulseaudio/releases/
|
||||
PKG_HASH:=809668ffc296043779c984f53461c2b3987a45b7a25eb2f0a1d11d9f23ba4055
|
||||
PKG_SOURCE_URL:=https://freedesktop.org/software/pulseaudio/releases
|
||||
PKG_HASH:=961b23ca1acfd28f2bc87414c27bb40e12436efcf2158d29721b1e89f3f28057
|
||||
|
||||
PKG_MAINTAINER:=Peter Wagner <tripolar@gmx.at>
|
||||
PKG_LICENSE:=LGPL-2.1-or-later
|
||||
PKG_LICENSE_FILES:=GPL LICENSE
|
||||
PKG_CPE_ID:=cpe:/a:pulseaudio:pulseaudio
|
||||
|
||||
PKG_FIXUP:=autoreconf
|
||||
PKG_INSTALL:=1
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
PKG_BUILD_DEPENDS:=intltool/host glib2/host
|
||||
PKG_USE_MIPS16:=0
|
||||
PKG_BUILD_DEPENDS:=meson/host
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include $(INCLUDE_DIR)/nls.mk
|
||||
include ../../devel/meson/meson.mk
|
||||
|
||||
define Package/pulseaudio/Default
|
||||
SECTION:=sound
|
||||
CATEGORY:=Sound
|
||||
DEPENDS:=+libsndfile +libltdl +libpthread +librt +alsa-lib \
|
||||
+libopenssl +libwrap +libcap $(ICONV_DEPENDS) $(INTL_DEPENDS)
|
||||
+libopenssl +libcap $(ICONV_DEPENDS) $(INTL_DEPENDS)
|
||||
TITLE:=Network sound server
|
||||
MAINTAINER:=Peter Wagner <tripolar@gmx.at>
|
||||
URL:=http://www.pulseaudio.org
|
||||
URL:=https://www.pulseaudio.org
|
||||
PROVIDES:=pulseaudio
|
||||
USERID:=pulse=51:pulse=51
|
||||
endef
|
||||
|
@ -96,47 +95,54 @@ define Package/pulseaudio-profiles
|
|||
URL:=http://www.pulseaudio.org
|
||||
endef
|
||||
|
||||
CONFIGURE_ARGS += \
|
||||
$(if $(findstring neon,$(CONFIG_TARGET_OPTIMIZATION)),--enable-neon-opt,--disable-neon-opt) \
|
||||
--with-system-user=pulse \
|
||||
--with-system-group=pulse \
|
||||
--with-access-group=audio \
|
||||
--with-database=simple \
|
||||
--enable-alsa \
|
||||
--disable-hal \
|
||||
--disable-gconf \
|
||||
--disable-nls \
|
||||
--disable-manpages \
|
||||
--enable-oss-output \
|
||||
--disable-oss-wrapper \
|
||||
--disable-samplerate \
|
||||
--disable-per-user-esound-socket \
|
||||
--disable-solaris \
|
||||
--disable-gtk2 \
|
||||
--disable-glib2 \
|
||||
--disable-jack \
|
||||
--disable-asyncns \
|
||||
--disable-lirc \
|
||||
--disable-tests \
|
||||
--disable-udev \
|
||||
--without-fftw \
|
||||
--without-soxr \
|
||||
--without-speex
|
||||
MESON_ARGS += \
|
||||
-Dgcov=false \
|
||||
-Dman=false \
|
||||
-Dtests=false \
|
||||
-Dsystem_user=pulse \
|
||||
-Dsystem_group=pulse \
|
||||
-Daccess_group=audio \
|
||||
-Ddatabase=simple \
|
||||
-Dlegacy-database-entry-format=false \
|
||||
-Drunning-from-build-tree=false \
|
||||
-Datomic-arm-linux-helpers=false \
|
||||
-Dalsa=enabled \
|
||||
-Dasyncns=disabled \
|
||||
-Dbluez5=false \
|
||||
-Dbluez5-native-headset=false \
|
||||
-Dbluez5-ofono-headset=false \
|
||||
-Dfftw=disabled \
|
||||
-Dglib=disabled \
|
||||
-Dgsettings=disabled \
|
||||
-Dgtk=disabled \
|
||||
-Dhal-compat=false \
|
||||
-Dipv6=true \
|
||||
-Djack=disabled \
|
||||
-Dlirc=disabled \
|
||||
-Dopenssl=enabled \
|
||||
-Dorc=disabled \
|
||||
-Dsamplerate=disabled \
|
||||
-Dsoxr=disabled \
|
||||
-Dspeex=disabled \
|
||||
-Dsystemd=disabled \
|
||||
-Dudev=disabled \
|
||||
-Dx11=disabled \
|
||||
-Dadrian-aec=true \
|
||||
-Dwebrtc-aec=disabled
|
||||
|
||||
ifeq ($(BUILD_VARIANT),avahi)
|
||||
CONFIGURE_ARGS += \
|
||||
--enable-avahi \
|
||||
--enable-dbus
|
||||
MESON_ARGS += \
|
||||
-Davahi=enabled \
|
||||
-Ddbus=enabled
|
||||
endif
|
||||
|
||||
ifeq ($(BUILD_VARIANT),noavahi)
|
||||
CONFIGURE_ARGS += \
|
||||
--disable-avahi \
|
||||
--disable-dbus
|
||||
MESON_ARGS += \
|
||||
-Davahi=disabled \
|
||||
-Ddbus=disabled
|
||||
endif
|
||||
|
||||
CONFIGURE_VARS += \
|
||||
PKG_CONFIG_LIBDIR="$(STAGING_DIR)/usr/lib/pkgconfig"
|
||||
TARGET_LDFLAGS += -liconv
|
||||
|
||||
define Build/InstallDev
|
||||
$(INSTALL_DIR) \
|
||||
|
|
|
@ -1,130 +0,0 @@
|
|||
From 993d3fd89e5611997f1e165bf03edefb0204b0a4 Mon Sep 17 00:00:00 2001
|
||||
From: Olaf Hering <olaf@aepfle.de>
|
||||
Date: Wed, 27 Mar 2019 09:35:05 +0100
|
||||
Subject: [PATCH] alsa: Use correct header path
|
||||
|
||||
Consumers are expected to use <alsa/asoundlib.h> instead of
|
||||
<asoundlib.h>.
|
||||
|
||||
This is in preparation of an change to pkgconfig(alsa) to
|
||||
not pollute CFLAGS with -I/usr/include/alsa anymore.
|
||||
|
||||
Signed-off-by: Olaf Hering <olaf@aepfle.de>
|
||||
---
|
||||
src/modules/alsa/alsa-mixer.c | 2 +-
|
||||
src/modules/alsa/alsa-mixer.h | 2 +-
|
||||
src/modules/alsa/alsa-sink.c | 2 +-
|
||||
src/modules/alsa/alsa-source.c | 2 +-
|
||||
src/modules/alsa/alsa-ucm.c | 2 +-
|
||||
src/modules/alsa/alsa-util.c | 2 +-
|
||||
src/modules/alsa/alsa-util.h | 2 +-
|
||||
src/modules/alsa/module-alsa-source.c | 2 +-
|
||||
8 files changed, 8 insertions(+), 8 deletions(-)
|
||||
|
||||
diff --git a/src/modules/alsa/alsa-mixer.c b/src/modules/alsa/alsa-mixer.c
|
||||
index 5cb99c8fd..cd99a75f8 100644
|
||||
--- a/src/modules/alsa/alsa-mixer.c
|
||||
+++ b/src/modules/alsa/alsa-mixer.c
|
||||
@@ -23,7 +23,7 @@
|
||||
#endif
|
||||
|
||||
#include <sys/types.h>
|
||||
-#include <asoundlib.h>
|
||||
+#include <alsa/asoundlib.h>
|
||||
#include <math.h>
|
||||
|
||||
#ifdef HAVE_VALGRIND_MEMCHECK_H
|
||||
diff --git a/src/modules/alsa/alsa-mixer.h b/src/modules/alsa/alsa-mixer.h
|
||||
index 3ea4d7329..65b071165 100644
|
||||
--- a/src/modules/alsa/alsa-mixer.h
|
||||
+++ b/src/modules/alsa/alsa-mixer.h
|
||||
@@ -21,7 +21,7 @@
|
||||
along with PulseAudio; if not, see <http://www.gnu.org/licenses/>.
|
||||
***/
|
||||
|
||||
-#include <asoundlib.h>
|
||||
+#include <alsa/asoundlib.h>
|
||||
|
||||
#include <pulse/sample.h>
|
||||
#include <pulse/mainloop-api.h>
|
||||
diff --git a/src/modules/alsa/alsa-sink.c b/src/modules/alsa/alsa-sink.c
|
||||
index 28143402a..4b46708ce 100644
|
||||
--- a/src/modules/alsa/alsa-sink.c
|
||||
+++ b/src/modules/alsa/alsa-sink.c
|
||||
@@ -25,7 +25,7 @@
|
||||
#include <signal.h>
|
||||
#include <stdio.h>
|
||||
|
||||
-#include <asoundlib.h>
|
||||
+#include <alsa/asoundlib.h>
|
||||
|
||||
#ifdef HAVE_VALGRIND_MEMCHECK_H
|
||||
#include <valgrind/memcheck.h>
|
||||
diff --git a/src/modules/alsa/alsa-source.c b/src/modules/alsa/alsa-source.c
|
||||
index 8129220b0..c8bf649e1 100644
|
||||
--- a/src/modules/alsa/alsa-source.c
|
||||
+++ b/src/modules/alsa/alsa-source.c
|
||||
@@ -25,7 +25,7 @@
|
||||
#include <signal.h>
|
||||
#include <stdio.h>
|
||||
|
||||
-#include <asoundlib.h>
|
||||
+#include <alsa/asoundlib.h>
|
||||
|
||||
#include <pulse/rtclock.h>
|
||||
#include <pulse/timeval.h>
|
||||
diff --git a/src/modules/alsa/alsa-ucm.c b/src/modules/alsa/alsa-ucm.c
|
||||
index 341c8012e..0a40ca8fe 100644
|
||||
--- a/src/modules/alsa/alsa-ucm.c
|
||||
+++ b/src/modules/alsa/alsa-ucm.c
|
||||
@@ -27,7 +27,7 @@
|
||||
#include <ctype.h>
|
||||
#include <sys/types.h>
|
||||
#include <limits.h>
|
||||
-#include <asoundlib.h>
|
||||
+#include <alsa/asoundlib.h>
|
||||
|
||||
#ifdef HAVE_VALGRIND_MEMCHECK_H
|
||||
#include <valgrind/memcheck.h>
|
||||
diff --git a/src/modules/alsa/alsa-util.c b/src/modules/alsa/alsa-util.c
|
||||
index e8d712e72..bd0a47e50 100644
|
||||
--- a/src/modules/alsa/alsa-util.c
|
||||
+++ b/src/modules/alsa/alsa-util.c
|
||||
@@ -23,7 +23,7 @@
|
||||
#endif
|
||||
|
||||
#include <sys/types.h>
|
||||
-#include <asoundlib.h>
|
||||
+#include <alsa/asoundlib.h>
|
||||
|
||||
#include <pulse/sample.h>
|
||||
#include <pulse/xmalloc.h>
|
||||
diff --git a/src/modules/alsa/alsa-util.h b/src/modules/alsa/alsa-util.h
|
||||
index 6b27339ec..4ceaa06ee 100644
|
||||
--- a/src/modules/alsa/alsa-util.h
|
||||
+++ b/src/modules/alsa/alsa-util.h
|
||||
@@ -21,7 +21,7 @@
|
||||
along with PulseAudio; if not, see <http://www.gnu.org/licenses/>.
|
||||
***/
|
||||
|
||||
-#include <asoundlib.h>
|
||||
+#include <alsa/asoundlib.h>
|
||||
|
||||
#include <pulse/sample.h>
|
||||
#include <pulse/channelmap.h>
|
||||
diff --git a/src/modules/alsa/module-alsa-source.c b/src/modules/alsa/module-alsa-source.c
|
||||
index af6800dd2..747ba9342 100644
|
||||
--- a/src/modules/alsa/module-alsa-source.c
|
||||
+++ b/src/modules/alsa/module-alsa-source.c
|
||||
@@ -24,7 +24,7 @@
|
||||
|
||||
#include <stdio.h>
|
||||
|
||||
-#include <asoundlib.h>
|
||||
+#include <alsa/asoundlib.h>
|
||||
|
||||
#ifdef HAVE_VALGRIND_MEMCHECK_H
|
||||
#include <valgrind/memcheck.h>
|
||||
--
|
||||
2.22.0
|
||||
|
Loading…
Reference in a new issue