motion: update to 4.3.1
Remove upstreamed patch. Added patch to remove man and po stuff to fix compilation and speed up the build. Added PKG_BUILD_PARALLEL for faster builds. Added PKG_INSTALL for consistency between packages. Used those install paths as well to make it easier. Other small cleanups for consistency between packages. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
d5a9a5a2c0
commit
78c0e2b06a
3 changed files with 36 additions and 34 deletions
|
@ -8,28 +8,30 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=motion
|
||||
PKG_VERSION:=4.2.2
|
||||
PKG_RELEASE:=3
|
||||
|
||||
PKG_MAINTAINER:=Roger D <rogerdammit@gmail.com>
|
||||
PKG_LICENSE:=GPLv2
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
PKG_CPE_ID:=cpe:/a:lavrsen:motion
|
||||
PKG_VERSION:=4.3.1
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-release-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/Motion-Project/motion/tar.gz/release-$(PKG_VERSION)?
|
||||
PKG_HASH:=c8d40976b41da8eb9f9f7128599403a312fc26b7226bf3787d75f78cb5a6cc6e
|
||||
PKG_HASH:=545712b10fc4a0134e994b7d8a3773c1c22f0bf4bd7afea7d7ffff357aca9ea5
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-release-$(PKG_VERSION)
|
||||
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
PKG_MAINTAINER:=Roger D <rogerdammit@gmail.com>
|
||||
PKG_LICENSE:=GPL-2.0-or-later
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
PKG_CPE_ID:=cpe:/a:lavrsen:motion
|
||||
|
||||
PKG_FIXUP:=autoreconf
|
||||
PKG_INSTALL:=1
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include $(INCLUDE_DIR)/nls.mk
|
||||
|
||||
define Package/motion
|
||||
SECTION:=multimedia
|
||||
CATEGORY:=Multimedia
|
||||
DEPENDS:=+libjpeg +libpthread +libmicrohttpd
|
||||
DEPENDS:=+libjpeg +libpthread +libmicrohttpd $(INTL_DEPENDS)
|
||||
TITLE:=webcam motion sensing and logging
|
||||
URL:=https://motion-project.github.io/
|
||||
endef
|
||||
|
@ -39,7 +41,7 @@ define Package/motion/conffiles
|
|||
/etc/motion.conf
|
||||
endef
|
||||
|
||||
CONFIGURE_ARGS+= \
|
||||
CONFIGURE_ARGS += \
|
||||
--without-optimizecpu \
|
||||
--without-ffmpeg \
|
||||
--without-jpeg-mmx \
|
||||
|
@ -54,9 +56,9 @@ define Package/motion/install
|
|||
$(INSTALL_DIR) $(1)/etc/config $(1)/etc/init.d
|
||||
$(INSTALL_CONF) ./files/motion.conf $(1)/etc/config/motion
|
||||
$(INSTALL_BIN) ./files/motion.init $(1)/etc/init.d/motion
|
||||
$(CP) $(PKG_BUILD_DIR)/motion-dist.conf $(1)/etc/motion.conf
|
||||
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/etc/motion/motion-dist.conf $(1)/etc/motion.conf
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/motion $(1)/usr/bin/
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/motion $(1)/usr/bin/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,motion))
|
||||
|
|
|
@ -1,21 +0,0 @@
|
|||
From c9bef916853c709fbf7f305da36da33ac4881660 Mon Sep 17 00:00:00 2001
|
||||
From: Mr-DaveDev <MotionMrDaveDev@gmail.com>
|
||||
Date: Sun, 1 Dec 2019 14:30:10 -0700
|
||||
Subject: [PATCH] Remove poll option for mhd
|
||||
|
||||
closes #1063
|
||||
---
|
||||
webu.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
--- a/webu.c
|
||||
+++ b/webu.c
|
||||
@@ -1828,7 +1828,7 @@ static void webu_mhd_opts(struct mhdstar
|
||||
static void webu_mhd_flags(struct mhdstart_ctx *mhdst){
|
||||
|
||||
/* This sets the MHD startup flags based upon what user put into configuration */
|
||||
- mhdst->mhd_flags = MHD_USE_THREAD_PER_CONNECTION | MHD_USE_POLL| MHD_USE_SELECT_INTERNALLY;
|
||||
+ mhdst->mhd_flags = MHD_USE_THREAD_PER_CONNECTION;
|
||||
|
||||
if (mhdst->ipv6) mhdst->mhd_flags = mhdst->mhd_flags | MHD_USE_DUAL_STACK;
|
||||
|
21
multimedia/motion/patches/010-no-po-man.patch
Normal file
21
multimedia/motion/patches/010-no-po-man.patch
Normal file
|
@ -0,0 +1,21 @@
|
|||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -1,6 +1,6 @@
|
||||
ACLOCAL_AMFLAGS = -I m4
|
||||
|
||||
-SUBDIRS = src po man
|
||||
+SUBDIRS = src
|
||||
|
||||
sysconfdir = @sysconfdir@/$(PACKAGE)
|
||||
sysconf_DATA = \
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -472,8 +472,6 @@ AC_SUBST(AM_LDFLAGS, "$TEMP_LDFLAGS")
|
||||
AC_CONFIG_FILES([
|
||||
Makefile
|
||||
src/Makefile
|
||||
- po/Makefile.in
|
||||
- man/Makefile
|
||||
data/camera1-dist.conf
|
||||
data/camera2-dist.conf
|
||||
data/camera3-dist.conf
|
Loading…
Reference in a new issue