pynacl: fix build with updated sodium-minimal patch
Commit3da874371
("libsodium: include ed25519_core in minimal build") broke the build of PyNaCl. Add patch to always include all ed25519 functions which are now always covered even if libsodium is built with the MINIMAL option. Signed-off-by: Daniel Golle <daniel@makrotopia.org> (cherry picked from commitccd3b6c0a5
)
This commit is contained in:
parent
e6330a60e7
commit
78aa0f6cac
2 changed files with 12 additions and 1 deletions
|
@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=python-pynacl
|
PKG_NAME:=python-pynacl
|
||||||
PKG_VERSION:=1.4.0
|
PKG_VERSION:=1.4.0
|
||||||
PKG_RELEASE:=5
|
PKG_RELEASE:=6
|
||||||
|
|
||||||
PYPI_NAME:=PyNaCl
|
PYPI_NAME:=PyNaCl
|
||||||
PKG_HASH:=54e9a2c849c742006516ad56a88f5c74bf2ce92c9f67435187c3c5953b346505
|
PKG_HASH:=54e9a2c849c742006516ad56a88f5c74bf2ce92c9f67435187c3c5953b346505
|
||||||
|
|
|
@ -9,3 +9,14 @@
|
||||||
static const int PYNACL_HAS_CRYPTO_SCALARMULT_ED25519 = 0;
|
static const int PYNACL_HAS_CRYPTO_SCALARMULT_ED25519 = 0;
|
||||||
|
|
||||||
size_t (*crypto_scalarmult_ed25519_bytes)() = NULL;
|
size_t (*crypto_scalarmult_ed25519_bytes)() = NULL;
|
||||||
|
--- a/src/bindings/minimal/crypto_core.h
|
||||||
|
+++ b/src/bindings/minimal/crypto_core.h
|
||||||
|
@@ -13,7 +13,7 @@
|
||||||
|
* limitations under the License.
|
||||||
|
*/
|
||||||
|
|
||||||
|
-#ifdef SODIUM_LIBRARY_MINIMAL
|
||||||
|
+#if 0
|
||||||
|
static const int PYNACL_HAS_CRYPTO_CORE_ED25519 = 0;
|
||||||
|
|
||||||
|
size_t (*crypto_core_ed25519_bytes)() = NULL;
|
Loading…
Reference in a new issue