commit
788596c778
2 changed files with 13 additions and 14 deletions
|
@ -8,15 +8,12 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=progress
|
PKG_NAME:=progress
|
||||||
PKG_VERSION:=0.13.1
|
PKG_VERSION:=0.14
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE_PROTO:=git
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=https://github.com/Xfennec/progress.git
|
PKG_SOURCE_URL:=https://codeload.github.com/Xfennec/progress/tar.gz/v$(PKG_VERSION)?
|
||||||
PKG_SOURCE_VERSION:=f6894b827c638af5cf8c5c622e66491c179ba2eb
|
PKG_HASH:=214a0d84b3ee5dde57ec9952ec9aa68ad9261fb336ef025324b344ed7ab48af1
|
||||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.xz
|
|
||||||
PKG_MIRROR_HASH:=143047dd44f78c10763446097bcadc551e99a7a8fefc484ef5a65d7bcbe8c181
|
|
||||||
|
|
||||||
PKG_MAINTAINER:=Nikil Mehta <nikil.mehta@gmail.com>
|
PKG_MAINTAINER:=Nikil Mehta <nikil.mehta@gmail.com>
|
||||||
PKG_LICENSE:=GPL-3.0
|
PKG_LICENSE:=GPL-3.0
|
||||||
|
|
|
@ -1,18 +1,20 @@
|
||||||
--- a/Makefile 2016-11-26 01:24:23.392903433 -0800
|
--- a/Makefile
|
||||||
+++ b/Makefile 2016-11-26 01:24:41.084939184 -0800
|
+++ b/Makefile
|
||||||
@@ -1,19 +1,6 @@
|
@@ -1,21 +1,7 @@
|
||||||
OBJ = progress
|
OBJ = progress
|
||||||
override CFLAGS += -g -Wall -D_FILE_OFFSET_BITS=64
|
CFLAGS ?= -g
|
||||||
|
override CFLAGS += -Wall -D_FILE_OFFSET_BITS=64
|
||||||
-override LDFLAGS += -lm
|
-override LDFLAGS += -lm
|
||||||
-UNAME := $(shell uname)
|
-UNAME := $(shell uname)
|
||||||
|
-PKG_CONFIG ?= pkg-config
|
||||||
-ifeq ($(UNAME), Linux)
|
-ifeq ($(UNAME), Linux)
|
||||||
- ifeq (, $(shell which pkg-config 2> /dev/null))
|
- ifeq (, $(shell which $(PKG_CONFIG) 2> /dev/null))
|
||||||
- $(error "pkg-config command not found")
|
- $(error "pkg-config command not found")
|
||||||
- endif
|
- endif
|
||||||
- ifeq (, $(shell pkg-config ncurses --libs 2> /dev/null))
|
- ifeq (, $(shell $(PKG_CONFIG) ncurses --libs 2> /dev/null))
|
||||||
- $(error "ncurses package not found")
|
- $(error "ncurses package not found")
|
||||||
- endif
|
- endif
|
||||||
- override LDFLAGS += $(shell pkg-config ncurses --libs)
|
- override LDFLAGS += $(shell $(PKG_CONFIG) ncurses --libs)
|
||||||
-endif
|
-endif
|
||||||
-ifeq ($(UNAME), Darwin)
|
-ifeq ($(UNAME), Darwin)
|
||||||
- override LDFLAGS += -lncurses
|
- override LDFLAGS += -lncurses
|
||||||
|
|
Loading…
Reference in a new issue