fbzmq: Fix compilation with newer GCC
Added -faligned-new to fix compilation.
As fbzmq is passing -Werror, fixed compilation with newer GCC versions.
Signed-off-by: Rosen Penev <rosenp@gmail.com>
(cherry-picked from 50f8657141
)
This commit is contained in:
parent
064528047e
commit
77b96a4ae4
2 changed files with 34 additions and 1 deletions
|
@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=fbzmq
|
||||
PKG_VERSION:=2019.06.10.00
|
||||
PKG_RELEASE:=2
|
||||
PKG_RELEASE:=3
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/facebook/fbzmq/tar.gz/v$(PKG_VERSION)?
|
||||
|
@ -37,6 +37,8 @@ CMAKE_OPTIONS += \
|
|||
-DTHRIFT1="$(STAGING_DIR_HOSTPKG)/bin/thrift1" \
|
||||
-DTHRIFT_COMPILER_INCLUDE="$(STAGING_DIR_HOSTPKG)/include/"
|
||||
|
||||
TARGET_CXXFLAGS += -faligned-new
|
||||
|
||||
define Package/fbzmq/install
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libfbzmq.so* $(1)/usr/lib/
|
||||
|
|
31
libs/fbzmq/patches/010-move.patch
Normal file
31
libs/fbzmq/patches/010-move.patch
Normal file
|
@ -0,0 +1,31 @@
|
|||
--- a/fbzmq/zmq/Message.cpp
|
||||
+++ b/fbzmq/zmq/Message.cpp
|
||||
@@ -35,7 +35,7 @@ Message::allocate(size_t size) noexcept {
|
||||
if (rc != 0) {
|
||||
return folly::makeUnexpected(Error());
|
||||
}
|
||||
- return std::move(msg);
|
||||
+ return msg;
|
||||
}
|
||||
|
||||
folly::Expected<Message, Error>
|
||||
@@ -58,7 +58,7 @@ Message::wrapBuffer(std::unique_ptr<folly::IOBuf> buf) noexcept {
|
||||
delete ptr;
|
||||
return folly::makeUnexpected(Error());
|
||||
}
|
||||
- return std::move(msg);
|
||||
+ return msg;
|
||||
}
|
||||
|
||||
Message&
|
||||
--- a/fbzmq/zmq/Socket.cpp
|
||||
+++ b/fbzmq/zmq/Socket.cpp
|
||||
@@ -449,7 +449,7 @@ SocketImpl::recv(int flags) const noexcept {
|
||||
while (true) {
|
||||
const int n = zmq_msg_recv(&(msg.msg_), ptr_, flags);
|
||||
if (n >= 0) {
|
||||
- return std::move(msg);
|
||||
+ return msg;
|
||||
}
|
||||
|
||||
const int err = zmq_errno();
|
Loading…
Reference in a new issue