samba4: update to 4.14.5
* update to 4.14.5 * refresh patches Signed-off-by: Andy Walsh <andy.walsh44+github@gmail.com>
This commit is contained in:
parent
d948dc938b
commit
7723235f47
7 changed files with 16 additions and 14 deletions
|
@ -2,7 +2,7 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=samba
|
||||
PKG_VERSION:=4.13.9
|
||||
PKG_VERSION:=4.14.5
|
||||
PKG_RELEASE:=$(AUTORELEASE)
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
|
@ -13,7 +13,7 @@ PKG_SOURCE_URL:= \
|
|||
http://www.nic.funet.fi/index/samba/pub/samba/stable/ \
|
||||
http://samba.mirror.bit.nl/samba/ftp/stable/ \
|
||||
https://download.samba.org/pub/samba/stable/
|
||||
PKG_HASH:=b97a773ed3b4dae6d5ebd3e09337c897ae898b65f38abad550f852b594d4e07f
|
||||
PKG_HASH:=bb6ef5d2f16b85288d823578abc453d9a80514c42e5a2ea2c4e3c60dc42335c3
|
||||
|
||||
PKG_MAINTAINER:=Andy Walsh <andy.walsh44+github@gmail.com>
|
||||
PKG_LICENSE:=GPL-3.0-only
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/source3/wscript
|
||||
+++ b/source3/wscript
|
||||
@@ -907,7 +907,7 @@ msg.msg_accrightslen = sizeof(fd);
|
||||
@@ -885,7 +885,7 @@ msg.msg_accrightslen = sizeof(fd);
|
||||
if conf.env.with_iconv:
|
||||
conf.DEFINE('HAVE_ICONV', 1)
|
||||
|
||||
|
@ -9,7 +9,7 @@
|
|||
use_pam=True
|
||||
conf.CHECK_HEADERS('security/pam_appl.h pam/pam_appl.h')
|
||||
if not conf.CONFIG_SET('HAVE_SECURITY_PAM_APPL_H') and not conf.CONFIG_SET('HAVE_PAM_PAM_APPL_H'):
|
||||
@@ -984,6 +984,17 @@ int i; i = PAM_RADIO_TYPE;
|
||||
@@ -962,6 +962,17 @@ int i; i = PAM_RADIO_TYPE;
|
||||
"or headers not found. Use --without-pam to disable "
|
||||
"PAM support.");
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/nsswitch/wins.c
|
||||
+++ b/nsswitch/wins.c
|
||||
@@ -39,6 +39,14 @@ static pthread_mutex_t wins_nss_mutex =
|
||||
@@ -40,6 +40,14 @@ static pthread_mutex_t wins_nss_mutex =
|
||||
#define INADDRSZ 4
|
||||
#endif
|
||||
|
||||
|
|
|
@ -22,5 +22,5 @@ Signed-off-by: Changqing Li <changqing.li@windriver.com>
|
|||
+#include <sys/stat.h>
|
||||
+#include <sys/types.h>
|
||||
|
||||
struct tevent_context;
|
||||
struct tevent_ops;
|
||||
/* for old gcc releases that don't have the feature test macro __has_attribute */
|
||||
#ifndef __has_attribute
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
--- a/source4/dsdb/samdb/ldb_modules/count_attrs.c
|
||||
+++ b/source4/dsdb/samdb/ldb_modules/count_attrs.c
|
||||
@@ -38,6 +38,11 @@
|
||||
#define NULL_REQ_PSEUDO_N -2LL;
|
||||
#define STAR_REQ_PSEUDO_N -4LL;
|
||||
@@ -40,6 +40,11 @@
|
||||
|
||||
#undef strcasecmp
|
||||
|
||||
+#ifndef __COMPAR_FN_T
|
||||
+#define __COMPAR_FN_T
|
||||
|
|
|
@ -1,6 +1,8 @@
|
|||
--- a/wscript_configure_embedded_heimdal
|
||||
+++ b/wscript_configure_embedded_heimdal
|
||||
@@ -1 +1,12 @@
|
||||
@@ -2,3 +2,14 @@ if not conf.env['FLEX']:
|
||||
conf.fatal("Embedded Heimdal build requires flex but it was not found. Install flex or use --with-system-mitkrb5 or --with-system-heimdalkrb5")
|
||||
|
||||
conf.RECURSE('source4/heimdal_build')
|
||||
+
|
||||
+def check_system_heimdal_binary(name):
|
||||
|
|
|
@ -29,7 +29,7 @@
|
|||
|
||||
conf.CHECK_CODE('''
|
||||
struct ucred cred;
|
||||
@@ -809,9 +800,6 @@ def configure(conf):
|
||||
@@ -807,9 +798,6 @@ def configure(conf):
|
||||
|
||||
# look for a method of finding the list of network interfaces
|
||||
for method in ['HAVE_IFACE_GETIFADDRS', 'HAVE_IFACE_AIX', 'HAVE_IFACE_IFCONF', 'HAVE_IFACE_IFREQ']:
|
||||
|
@ -39,7 +39,7 @@
|
|||
if conf.CHECK_CODE('''
|
||||
#define %s 1
|
||||
#define NO_CONFIG_H 1
|
||||
@@ -824,7 +812,7 @@ def configure(conf):
|
||||
@@ -822,7 +810,7 @@ def configure(conf):
|
||||
#include "tests/getifaddrs.c"
|
||||
''' % method,
|
||||
method,
|
||||
|
@ -48,7 +48,7 @@
|
|||
addmain=False,
|
||||
execute=True):
|
||||
break
|
||||
@@ -872,7 +860,6 @@ def build(bld):
|
||||
@@ -870,7 +858,6 @@ def build(bld):
|
||||
break
|
||||
|
||||
extra_libs = ''
|
||||
|
|
Loading…
Reference in a new issue