Merge pull request #10453 from commodo/python3-fix-build
python3: fix build on Ubuntu/Debian multi-arch
This commit is contained in:
commit
75f958e3ce
2 changed files with 13 additions and 1 deletions
|
@ -14,7 +14,7 @@ PYTHON_VERSION:=$(PYTHON3_VERSION)
|
|||
PYTHON_VERSION_MICRO:=$(PYTHON3_VERSION_MICRO)
|
||||
|
||||
PKG_NAME:=python3
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=$(PYTHON_VERSION).$(PYTHON_VERSION_MICRO)
|
||||
|
||||
PKG_SOURCE:=Python-$(PKG_VERSION).tar.xz
|
||||
|
|
|
@ -0,0 +1,12 @@
|
|||
--- a/setup.py
|
||||
+++ b/setup.py
|
||||
@@ -654,7 +654,8 @@ class PyBuildExt(build_ext):
|
||||
# only change this for cross builds for 3.3, issues on Mageia
|
||||
if CROSS_COMPILING:
|
||||
self.add_cross_compiling_paths()
|
||||
- self.add_multiarch_paths()
|
||||
+ else:
|
||||
+ self.add_multiarch_paths()
|
||||
self.add_ldflags_cppflags()
|
||||
|
||||
def init_inc_lib_dirs(self):
|
Loading…
Reference in a new issue