tang: Update to version 7
Added License information. Cleaned up Makefile for consistency between packages. Added numerical prefixes to the patches for clarity. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
d53191e3f9
commit
75eb09638d
4 changed files with 17 additions and 33 deletions
|
@ -8,17 +8,20 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=tang
|
||||
PKG_VERSION:=6
|
||||
PKG_VERSION:=7
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=https://github.com/latchset/$(PKG_NAME)/releases/download/v$(PKG_VERSION)/
|
||||
PKG_HASH:=1df78b48a52d2ca05656555cfe52bd4427c884f5a54a2c5e37a7b39da9e155e3
|
||||
PKG_HASH:=fbe13e4e3103cd24cada7824b63e510cffd650832ecd075fd49b99475a4f9bfa
|
||||
|
||||
PKG_INSTALL:=1
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
PKG_MAINTAINER:=Tibor Dudlák <tibor.dudlak@gmail.com>
|
||||
PKG_LICENSE:=GPL-3.0-or-later
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
|
||||
PKG_FIXUP:=autoreconf
|
||||
PKG_INSTALL:=1
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
|
@ -27,7 +30,6 @@ define Package/tang
|
|||
TITLE:=tang v$(PKG_VERSION) - daemon for binding data to the presence of a third party
|
||||
DEPENDS:=+libhttp-parser +xinetd +jose +bash
|
||||
URL:=https://github.com/latchset/tang
|
||||
MAINTAINER:=Tibor Dudlák <tibor.dudlak@gmail.com>
|
||||
endef
|
||||
|
||||
define Package/tang/description
|
||||
|
|
|
@ -1,14 +1,11 @@
|
|||
diff --git a/Makefile.am b/Makefile.am
|
||||
index 14bf91d..dfa6d07 100644
|
||||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -1,5 +1,3 @@
|
||||
@@ -1,4 +1,3 @@
|
||||
-DISTCHECK_CONFIGURE_FLAGS = --with-systemdsystemunitdir=$$dc_install_base/$(systemdsystemunitdir)
|
||||
-
|
||||
AM_CFLAGS = @TANG_CFLAGS@ @jose_CFLAGS@
|
||||
LDADD = @jose_LIBS@ @http_parser_LIBS@
|
||||
|
||||
@@ -7,21 +5,11 @@ nagiosdir = $(libdir)/nagios/plugins
|
||||
BUILT_SOURCES=
|
||||
CLEANFILES=
|
||||
man1_MANS=
|
||||
@@ -10,13 +9,6 @@ LDADD = @jose_LIBS@ @http_parser_LIBS@
|
||||
cachedir = $(localstatedir)/cache/$(PACKAGE_NAME)
|
||||
jwkdir = $(localstatedir)/db/$(PACKAGE_NAME)
|
||||
|
||||
|
@ -20,26 +17,15 @@ index 14bf91d..dfa6d07 100644
|
|||
- units/tangd-keygen.service
|
||||
-
|
||||
dist_libexec_SCRIPTS = src/tangd-update src/tangd-keygen
|
||||
dist_bin_SCRIPTS = src/tang-show-keys
|
||||
libexec_PROGRAMS = src/tangd
|
||||
-nagios_PROGRAMS = src/tang
|
||||
-man1_MANS = doc/tang-nagios.1
|
||||
man8_MANS = doc/tang.8
|
||||
|
||||
src_tangd_SOURCES = src/http.c src/http.h src/tangd.c
|
||||
-src_tang_SOURCES = src/nagios.c
|
||||
|
||||
%: %.in
|
||||
$(AM_V_GEN)mkdir -p "`dirname "$@"`"
|
||||
@@ -32,11 +20,9 @@ src_tang_SOURCES = src/nagios.c
|
||||
$(srcdir)/$@.in > $@
|
||||
|
||||
@@ -52,9 +44,7 @@ src_tangd_SOURCES = src/http.c src/http.h src/tangd.c
|
||||
AM_TESTS_ENVIRONMENT = SD_ACTIVATE="@SD_ACTIVATE@" PATH=$(srcdir)/src:$(builddir)/src:$(PATH)
|
||||
-TESTS = tests/adv tests/rec tests/nagios
|
||||
+TESTS = tests/adv tests/rec
|
||||
TESTS = tests/adv tests/rec
|
||||
|
||||
-CLEANFILES = $(nodist_systemdsystemunit_DATA)
|
||||
-CLEANFILES += $(nodist_systemdsystemunit_DATA)
|
||||
EXTRA_DIST = \
|
||||
- $(foreach unit,$(nodist_systemdsystemunit_DATA),$(unit).in) \
|
||||
COPYING \
|
||||
$(TESTS) \
|
||||
$(man1_MANS) \
|
||||
$(man_ADOC_FILES)
|
|
@ -1,5 +1,3 @@
|
|||
diff --git a/configure.ac b/configure.ac
|
||||
index b51bb31..4b37d30 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -27,32 +27,6 @@ AC_CHECK_LIB([http_parser], [http_parser_execute],
|
|
@ -1,5 +1,3 @@
|
|||
diff --git a/src/tangd-update b/src/tangd-update
|
||||
index 652dbef..01aa842 100755
|
||||
--- a/src/tangd-update
|
||||
+++ b/src/tangd-update
|
||||
@@ -33,8 +33,8 @@ fi
|
Loading…
Reference in a new issue