Merge pull request #22545 from mhei/gensio-update-to-2.7.6
gensio: update to 2.7.6
This commit is contained in:
commit
756ba29568
2 changed files with 19 additions and 16 deletions
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=gensio
|
||||
PKG_VERSION:=2.4.2
|
||||
PKG_VERSION:=2.7.6
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@SF/ser2net
|
||||
PKG_HASH:=2593c1e7beaec3a0a4acbf60f94bbf64b99883d86f172a3b584eba5f67441b4b
|
||||
PKG_HASH:=7574fb710ddd6580d53ea44af4ddfc57f28dbcdc646d842f7ed8ccc1235fdf89
|
||||
|
||||
PKG_LICENSE:=GPL-2.0-or-later
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
|
@ -39,15 +39,25 @@ include $(INCLUDE_DIR)/package.mk
|
|||
include ../../lang/python/python3-package.mk
|
||||
|
||||
CONFIGURE_ARGS += \
|
||||
--$(if $(CONFIG_GENSIO_AVAHI),with,without)-avahi \
|
||||
--$(if $(CONFIG_GENSIO_SSL),with,without)-openssl \
|
||||
--$(if $(CONFIG_GENSIO_SCTP),with,without)-sctp \
|
||||
--$(if $(CONFIG_GENSIO_WRAP),with,without)-tcp-wrappers \
|
||||
--$(if $(CONFIG_GENSIO_PTHREADS),with,without)-pthreads \
|
||||
--$(if $(CONFIG_GENSIO_GLIB),with,without)-glib \
|
||||
--$(if $(CONFIG_GENSIO_TCL),with,without)-tcl \
|
||||
--without-afskmdm \
|
||||
--without-ax25 \
|
||||
--without-alsa \
|
||||
--without-go \
|
||||
--without-ipmisol \
|
||||
--without-kiss \
|
||||
--without-openipmi \
|
||||
--without-portaudio \
|
||||
--without-sound \
|
||||
--with-cplusplus \
|
||||
--with-flock-locking \
|
||||
--with-uucp-locking \
|
||||
--disable-doc
|
||||
|
||||
CONFIGURE_VARS += \
|
||||
|
@ -161,8 +171,9 @@ endef
|
|||
define Build/InstallDev
|
||||
$(INSTALL_DIR) $(1)/usr/include/gensio/
|
||||
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/include/gensio/* $(1)/usr/include/gensio/
|
||||
$(INSTALL_DIR) $(1)/usr/lib/
|
||||
$(INSTALL_DIR) $(1)/usr/lib/gensio
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/*.{so*,a,la} $(1)/usr/lib/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/gensio/* $(1)/usr/lib/gensio/
|
||||
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig/
|
||||
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/* $(1)/usr/lib/pkgconfig/
|
||||
ifneq ($(CONFIG_PACKAGE_python3-gensio),)
|
||||
|
@ -173,8 +184,11 @@ endif
|
|||
endef
|
||||
|
||||
define Package/libgensio/install
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(INSTALL_DIR) $(1)/usr/lib/gensio
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libgensio.so.* $(1)/usr/lib/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libgensioosh.so.* $(1)/usr/lib/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libgensiomdns.so.* $(1)/usr/lib/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/gensio/* $(1)/usr/lib/gensio/
|
||||
ifeq ($(CONFIG_GENSIO_GLIB),y)
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libgensioglib.so.* $(1)/usr/lib/
|
||||
endif
|
||||
|
@ -200,7 +214,7 @@ endef
|
|||
|
||||
define Package/libgensiocpp/install
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libgensiocpp.so.* $(1)/usr/lib/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libgensio*cpp.so.* $(1)/usr/lib/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,libgensio))
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- a/tools/gensiotool.c
|
||||
+++ b/tools/gensiotool.c
|
||||
@@ -44,7 +44,7 @@
|
||||
#include <signal.h>
|
||||
#include <errno.h>
|
||||
#include <sys/types.h>
|
||||
-#include <sys/unistd.h>
|
||||
+#include <unistd.h>
|
||||
#include <syslog.h>
|
||||
#endif
|
||||
|
Loading…
Reference in a new issue