wifidog: fix compilation with more recent wolfssl
Needs an extra header. pthread.h is also no longer implicitly included.
Signed-off-by: Rosen Penev <rosenp@gmail.com>
(cherry picked from commit 4605f98b41
)
This commit is contained in:
parent
ef545e0317
commit
756a3243dc
2 changed files with 19 additions and 1 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=wifidog
|
||||
PKG_VERSION:=1.3.0
|
||||
PKG_RELEASE:=6
|
||||
PKG_RELEASE:=7
|
||||
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_URL:=https://github.com/wifidog/wifidog-gateway
|
||||
|
|
18
net/wifidog/patches/030-wolfssl-options.patch
Normal file
18
net/wifidog/patches/030-wolfssl-options.patch
Normal file
|
@ -0,0 +1,18 @@
|
|||
--- a/src/simple_http.c
|
||||
+++ b/src/simple_http.c
|
||||
@@ -28,6 +28,7 @@
|
||||
#include <arpa/inet.h>
|
||||
#include <errno.h>
|
||||
#include <unistd.h>
|
||||
+#include <pthread.h>
|
||||
#include <string.h>
|
||||
#include <syslog.h>
|
||||
|
||||
@@ -37,6 +38,7 @@
|
||||
#include "pstring.h"
|
||||
|
||||
#ifdef USE_CYASSL
|
||||
+#include <cyassl/options.h>
|
||||
#include <cyassl/ssl.h>
|
||||
#include "conf.h"
|
||||
/* For CYASSL_MAX_ERROR_SZ */
|
Loading…
Reference in a new issue