stress-ng: bump to version 0.12.04
Refreshed patch.
Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
(cherry picked from commit 987c82cc73
)
This commit is contained in:
parent
23925c77a7
commit
752da2a8b9
2 changed files with 4 additions and 4 deletions
|
@ -6,12 +6,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=stress-ng
|
||||
PKG_VERSION:=0.12.02
|
||||
PKG_VERSION:=0.12.04
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=https://kernel.ubuntu.com/~cking/tarballs/stress-ng
|
||||
PKG_HASH:=f847be115f60d3ad7d37c806fd1bfb1412aa3c631fca581d6dc233322f50d6a5
|
||||
PKG_HASH:=b4e34bda8db4ed37e33b7a861bc06ad77cbbd234d63236da2cb58f02e3f3218e
|
||||
|
||||
PKG_MAINTAINER:=Alexandru Ardelean <ardeleanalex@gmail.com>
|
||||
PKG_LICENSE:=GPL-2.0-only
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/stress-fp-error.c
|
||||
+++ b/stress-fp-error.c
|
||||
@@ -115,42 +115,43 @@ static int stress_fp_error(const stress_
|
||||
@@ -117,42 +117,43 @@ static int stress_fp_error(const stress_
|
||||
do {
|
||||
volatile double d1, d2;
|
||||
|
||||
|
@ -50,7 +50,7 @@
|
|||
/*
|
||||
* Use volatiles to force compiler to generate code
|
||||
* to perform run time computation of 1.0 / M_PI
|
||||
@@ -171,14 +172,15 @@ static int stress_fp_error(const stress_
|
||||
@@ -173,14 +174,15 @@ static int stress_fp_error(const stress_
|
||||
stress_fp_check(args, "DBL_MAX + DBL_MAX / 2.0",
|
||||
DBL_MAX + DBL_MAX / 2.0, INFINITY,
|
||||
false, true, 0, FE_OVERFLOW | FE_INEXACT);
|
||||
|
|
Loading…
Reference in a new issue