vips: update to 8.10.2
Signed-off-by: W. Michael Petullo <mike@flyn.org>
This commit is contained in:
parent
78dd3e05a8
commit
74e30ea924
3 changed files with 20 additions and 22 deletions
|
@ -6,12 +6,12 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=vips
|
PKG_NAME:=vips
|
||||||
PKG_VERSION:=8.8.3
|
PKG_VERSION:=8.10.2
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=https://github.com/libvips/libvips/releases/download/v$(PKG_VERSION)
|
PKG_SOURCE_URL:=https://github.com/libvips/libvips/releases/download/v$(PKG_VERSION)
|
||||||
PKG_HASH:=c5e4dd5a5c6a777c129037d19ca606769b3f1d405fcc9c8eeda906a61491f790
|
PKG_HASH:=c1d0d9cb54d75cd4f66dce787fbcac99f834f6621fbf47bce9e02ef65b4ab02a
|
||||||
|
|
||||||
PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
|
PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
|
||||||
PKG_LICENSE:=LGPL-2.1-or-later
|
PKG_LICENSE:=LGPL-2.1-or-later
|
||||||
|
|
|
@ -1,18 +1,20 @@
|
||||||
--- a/configure.ac
|
diff -u --recursive vips-8.10.2-vanilla/configure.ac vips-8.10.2/configure.ac
|
||||||
+++ b/configure.ac
|
--- vips-8.10.2-vanilla/configure.ac 2020-10-12 11:43:59.000000000 -0500
|
||||||
@@ -53,9 +53,6 @@ AC_SUBST(LIBRARY_CURRENT)
|
+++ vips-8.10.2/configure.ac 2020-11-19 12:17:39.393295442 -0600
|
||||||
|
@@ -53,9 +53,6 @@
|
||||||
AC_SUBST(LIBRARY_REVISION)
|
AC_SUBST(LIBRARY_REVISION)
|
||||||
AC_SUBST(LIBRARY_AGE)
|
AC_SUBST(LIBRARY_AGE)
|
||||||
|
|
||||||
-# init introspection support
|
-# init introspection support
|
||||||
-GOBJECT_INTROSPECTION_CHECK([1.30.0])
|
-GOBJECT_INTROSPECTION_CHECK([1.30.0])
|
||||||
-
|
-
|
||||||
# gir needs a list of source files to scan for introspection
|
# remove the '(disabled, use --enable-introspection to enable)'
|
||||||
#
|
# suffix from the found_introspection variable
|
||||||
# build with a glob and a list of files to exclude from scanning
|
if test "x$found_introspection" != x"yes"; then
|
||||||
--- a/libvips/Makefile.am
|
diff -u --recursive vips-8.10.2-vanilla/libvips/Makefile.am vips-8.10.2/libvips/Makefile.am
|
||||||
+++ b/libvips/Makefile.am
|
--- vips-8.10.2-vanilla/libvips/Makefile.am 2020-09-14 10:38:03.000000000 -0500
|
||||||
@@ -68,56 +68,3 @@ install-exec-hook:
|
+++ vips-8.10.2/libvips/Makefile.am 2020-11-19 12:18:08.473384766 -0600
|
||||||
|
@@ -67,56 +67,3 @@
|
||||||
echo "#define VIPS_SONAME \"$$dlname\"" >> soname.h && \
|
echo "#define VIPS_SONAME \"$$dlname\"" >> soname.h && \
|
||||||
cp soname.h $(DESTDIR)$(pkgincludedir) && \
|
cp soname.h $(DESTDIR)$(pkgincludedir) && \
|
||||||
rm soname.h
|
rm soname.h
|
||||||
|
@ -35,7 +37,7 @@
|
||||||
-LDADD = @INTROSPECTION_LIBS@ @VIPS_CFLAGS@ libvips.la @VIPS_LIBS@
|
-LDADD = @INTROSPECTION_LIBS@ @VIPS_CFLAGS@ libvips.la @VIPS_LIBS@
|
||||||
-
|
-
|
||||||
-noinst_PROGRAMS = \
|
-noinst_PROGRAMS = \
|
||||||
- introspect
|
- introspect$(EXEEXT)
|
||||||
-introspect_SOURCES = \
|
-introspect_SOURCES = \
|
||||||
- introspect.c
|
- introspect.c
|
||||||
-
|
-
|
||||||
|
@ -44,7 +46,7 @@
|
||||||
-introspection_sources = @vips_introspection_sources@
|
-introspection_sources = @vips_introspection_sources@
|
||||||
-
|
-
|
||||||
-# we make the vips8 API
|
-# we make the vips8 API
|
||||||
-Vips-8.0.gir: introspect
|
-Vips-8.0.gir: introspect$(EXEEXT)
|
||||||
-Vips_8_0_gir_INCLUDES = GObject-2.0
|
-Vips_8_0_gir_INCLUDES = GObject-2.0
|
||||||
-Vips_8_0_gir_CFLAGS = $(INCLUDES) -I${top_srcdir}/libvips/include
|
-Vips_8_0_gir_CFLAGS = $(INCLUDES) -I${top_srcdir}/libvips/include
|
||||||
-Vips_8_0_gir_LIBS = libvips.la
|
-Vips_8_0_gir_LIBS = libvips.la
|
||||||
|
|
|
@ -1,15 +1,11 @@
|
||||||
Description: Make the build reproducible
|
diff -u --recursive vips-8.10.2-vanilla/configure.ac vips-8.10.2/configure.ac
|
||||||
Author: Chris Lamb <lamby@debian.org>
|
--- vips-8.10.2-vanilla/configure.ac 2020-10-12 11:43:59.000000000 -0500
|
||||||
Reviewed-By: Laszlo Boszormenyi (GCS) <gcs@debian.org>
|
+++ vips-8.10.2/configure.ac 2020-11-19 12:16:45.187129100 -0600
|
||||||
Last-Update: 2018-07-24
|
@@ -26,7 +26,11 @@
|
||||||
|
|
||||||
--- vips-8.6.4.orig/configure.ac
|
|
||||||
+++ vips-8.6.4/configure.ac
|
|
||||||
@@ -26,7 +26,11 @@ VIPS_MAJOR_VERSION=vips_major_version()
|
|
||||||
VIPS_MINOR_VERSION=vips_minor_version()
|
VIPS_MINOR_VERSION=vips_minor_version()
|
||||||
VIPS_MICRO_VERSION=vips_micro_version()
|
VIPS_MICRO_VERSION=vips_micro_version()
|
||||||
VIPS_VERSION=vips_version()
|
VIPS_VERSION=vips_version()
|
||||||
-VIPS_VERSION_STRING=$VIPS_VERSION-`date -u -r ChangeLog`
|
-VIPS_VERSION_STRING=$VIPS_VERSION-`date -u -r $srcdir/ChangeLog`
|
||||||
+if test "x$SOURCE_DATE_EPOCH" = "x"; then
|
+if test "x$SOURCE_DATE_EPOCH" = "x"; then
|
||||||
+ VIPS_VERSION_STRING=$VIPS_VERSION-`date -u -r ChangeLog`
|
+ VIPS_VERSION_STRING=$VIPS_VERSION-`date -u -r ChangeLog`
|
||||||
+else
|
+else
|
||||||
|
|
Loading…
Reference in a new issue