ffmpeg: Fix pkgconfig files to be more cross compile friendly
Before: prefix=/usr exec_prefix=${prefix} libdir=/usr/lib includedir=/usr/include After: prefix=/usr exec_prefix=/usr libdir=${exec_prefix}/lib includedir=${prefix}/include Numbered the other patch file. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
1086846107
commit
7477663489
3 changed files with 16 additions and 1 deletions
|
@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=ffmpeg
|
||||
PKG_VERSION:=3.4.6
|
||||
PKG_RELEASE:=3
|
||||
PKG_RELEASE:=4
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=https://ffmpeg.org/releases/
|
||||
|
|
15
multimedia/ffmpeg/patches/010-pkgconfig.patch
Normal file
15
multimedia/ffmpeg/patches/010-pkgconfig.patch
Normal file
|
@ -0,0 +1,15 @@
|
|||
--- a/ffbuild/pkgconfig_generate.sh
|
||||
+++ b/ffbuild/pkgconfig_generate.sh
|
||||
@@ -28,9 +28,9 @@ version=$(grep ${name}_VERSION= $name/${name}.version | cut -d= -f2)
|
||||
|
||||
cat <<EOF > $name/$fullname.pc
|
||||
prefix=$prefix
|
||||
-exec_prefix=\${prefix}
|
||||
-libdir=$libdir
|
||||
-includedir=$incdir
|
||||
+exec_prefix=${prefix}
|
||||
+libdir=\${exec_prefix}/lib
|
||||
+includedir=\${prefix}/include
|
||||
|
||||
Name: $fullname
|
||||
Description: $comment
|
Loading…
Reference in a new issue