minidlna: update to 1.3.2 release
- Updated to latest version - Removed upstreamed patches - Refreshed patches Project changelog: 1.3.2 - Released 30-Aug-2022 -------------------------------- - Improved DNS rebinding attack protection. - Added Samsung Neo QLED series (2021) support. - Added webm/rm/rmvb support. 1.3.1 - Released 11-Feb-2022 -------------------------------- - Fixed a potential crash in SSDP request parsing. - Fixed a configure script failure on some platforms. - Protect against DNS rebinding attacks. - Fix an socket leakage issue on some platforms. - Minor bug fixes. Signed-off-by: Andrew Sim <andrewsimz@gmail.com>
This commit is contained in:
parent
d347448ffb
commit
73d89cb4d6
4 changed files with 4 additions and 93 deletions
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=minidlna
|
||||
PKG_VERSION:=1.3.0
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=1.3.2
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@SF/minidlna
|
||||
PKG_HASH:=47d9b06b4c48801a4c1112ec23d24782728b5495e95ec2195bbe5c81bc2d3c63
|
||||
PKG_HASH:=222ce45a1a60c3ce3de17527955d38e5ff7a4592d61db39577e6bf88e0ae1cb0
|
||||
|
||||
PKG_MAINTAINER:=
|
||||
PKG_LICENSE:=GPL-2.0-or-later BSD-3-Clause
|
||||
|
|
|
@ -1,34 +0,0 @@
|
|||
From 8d8d04785bdc8d743d8a1fcfadd1285d86670b1e
|
||||
From: Justin Maggard <jmaggard@arlo.com>
|
||||
Date: Wed, 9 Feb 2022 18:32:19 -0800
|
||||
Subject: [PATCH] build: Fix configure error on some platforms
|
||||
|
||||
Fixes libid3tag and libavformat detection errors.
|
||||
---
|
||||
configure.ac | 8 ++++++--
|
||||
1 file changed, 6 insertions(+), 2 deletions(-)
|
||||
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -414,7 +414,10 @@ for dir in "" /usr/local $SEARCH_DIR; do
|
||||
AC_CHECK_LIB([id3tag -lz], [id3_file_open], [LIBID3TAG_LIBS="-lid3tag -lz"], [unset ac_cv_lib_id3tag_id3_file_open; LDFLAGS="$LDFLAGS_SAVE"; continue])
|
||||
break
|
||||
done
|
||||
-test x"$ac_cv_lib_id3tag__lz___id3_file_open" = x"yes" || AC_MSG_ERROR([Could not find libid3tag])
|
||||
+if test x"$ac_cv_lib_id3tag__lz___id3_file_open" != x"yes" &&
|
||||
+ test x"$ac_cv_lib_id3tag__lz_id3_file_open" != x"yes"; then
|
||||
+ AC_MSG_ERROR([Could not find libid3tag])
|
||||
+fi
|
||||
AC_SUBST(LIBID3TAG_LIBS)
|
||||
|
||||
LDFLAGS_SAVE="$LDFLAGS"
|
||||
@@ -441,7 +444,8 @@ for dir in "" /usr/local $SEARCH_DIR; do
|
||||
break
|
||||
done
|
||||
if test x"$ac_cv_lib_avformat__lavcodec__lavutil__lz___av_open_input_file" != x"yes" &&
|
||||
- test x"$ac_cv_lib_avformat__lavcodec__lavutil__lz___avformat_open_input" != x"yes"; then
|
||||
+ test x"$ac_cv_lib_avformat__lavcodec__lavutil__lz___avformat_open_input" != x"yes" &&
|
||||
+ test x"$ac_cv_lib_avformat__lavcodec__lavutil__lz_avformat_open_input" != x"yes"; then
|
||||
AC_MSG_ERROR([Could not find libavformat - part of ffmpeg])
|
||||
fi
|
||||
AC_SUBST(LIBAVFORMAT_LIBS)
|
|
@ -11,7 +11,7 @@
|
|||
check_PROGRAMS = testupnpdescgen
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -662,6 +662,5 @@ case "$target_os" in
|
||||
@@ -670,6 +670,5 @@ case "$target_os" in
|
||||
esac
|
||||
|
||||
|
||||
|
|
|
@ -1,55 +0,0 @@
|
|||
From e4a045e92b864dc148ca46be94668c5b67132405 Mon Sep 17 00:00:00 2001
|
||||
From: VergLsm <vision.lsm.2012@gmail.com>
|
||||
Date: Fri, 31 Jan 2020 10:01:12 +0000
|
||||
Subject: [PATCH] Added support RMVB.
|
||||
|
||||
---
|
||||
metadata.c | 4 ++++
|
||||
upnpglobalvars.h | 3 ++-
|
||||
utils.c | 3 +++
|
||||
3 files changed, 9 insertions(+), 1 deletion(-)
|
||||
|
||||
--- a/metadata.c
|
||||
+++ b/metadata.c
|
||||
@@ -862,6 +862,10 @@ GetVideoMetadata(const char *path, const
|
||||
xasprintf(&m.mime, "video/x-matroska");
|
||||
else if( strcmp(ctx->iformat->name, "flv") == 0 )
|
||||
xasprintf(&m.mime, "video/x-flv");
|
||||
+ else if( strcmp(ctx->iformat->name, "rm") == 0 )
|
||||
+ xasprintf(&m.mime, "video/x-pn-realvideo");
|
||||
+ else if( strcmp(ctx->iformat->name, "rmvb") == 0 )
|
||||
+ xasprintf(&m.mime, "video/x-pn-realvideo");
|
||||
if( m.mime )
|
||||
goto video_no_dlna;
|
||||
|
||||
--- a/upnpglobalvars.h
|
||||
+++ b/upnpglobalvars.h
|
||||
@@ -172,7 +172,8 @@
|
||||
"http-get:*:audio/x-wav:*," \
|
||||
"http-get:*:audio/x-flac:*," \
|
||||
"http-get:*:audio/x-dsd:*," \
|
||||
- "http-get:*:application/ogg:*"
|
||||
+ "http-get:*:application/ogg:*,"\
|
||||
+ "http-get:*:video/x-pn-realvideo:*"
|
||||
|
||||
#define DLNA_FLAG_DLNA_V1_5 0x00100000
|
||||
#define DLNA_FLAG_HTTP_STALLING 0x00200000
|
||||
--- a/utils.c
|
||||
+++ b/utils.c
|
||||
@@ -377,6 +377,8 @@ mime_to_ext(const char * mime)
|
||||
return "3gp";
|
||||
else if( strncmp(mime+6, "x-tivo-mpeg", 11) == 0 )
|
||||
return "TiVo";
|
||||
+ else if( strcmp(mime+6, "x-pn-realvideo") == 0 )
|
||||
+ return "rm";
|
||||
break;
|
||||
case 'i':
|
||||
if( strcmp(mime+6, "jpeg") == 0 )
|
||||
@@ -401,6 +403,7 @@ is_video(const char * file)
|
||||
ends_with(file, ".m2t") || ends_with(file, ".mkv") ||
|
||||
ends_with(file, ".vob") || ends_with(file, ".ts") ||
|
||||
ends_with(file, ".flv") || ends_with(file, ".xvid") ||
|
||||
+ ends_with(file, ".rm") || ends_with(file, ".rmvb") ||
|
||||
#ifdef TIVO_SUPPORT
|
||||
ends_with(file, ".TiVo") ||
|
||||
#endif
|
Loading…
Reference in a new issue