memcached: Update to 1.5.14
Fixes compilation with GCC8. Remove obsolete patch. Small Makefile cleanups. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
54e868c822
commit
73ce3f5e6c
2 changed files with 4 additions and 36 deletions
|
@ -9,15 +9,14 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=memcached
|
||||
PKG_VERSION:=1.5.2
|
||||
PKG_VERSION:=1.5.14
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://memcached.org/files
|
||||
PKG_HASH:=9ac93113bdb5d037e79c61277386564ac2e5e31d49e594f11e554e4c149b7245
|
||||
PKG_SOURCE_URL:=https://memcached.org/files
|
||||
PKG_HASH:=9c5bdf29a780fb6c6f7c9eaaeeda0583efdf663193758c3e316c969a510af2a9
|
||||
|
||||
PKG_MAINTAINER:=Thomas Heil <heil@terminal-consulting.de>
|
||||
|
||||
PKG_LICENSE:=BSD-3-Clause
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
|
||||
|
@ -30,7 +29,7 @@ define Package/memcached
|
|||
CATEGORY:=Network
|
||||
DEPENDS:=+libevent2 +libpthread
|
||||
TITLE:=The high-performance, distributed memory object caching system
|
||||
URL:=http://memcached.org/
|
||||
URL:=https://memcached.org/
|
||||
endef
|
||||
|
||||
define Package/memcached/description
|
||||
|
@ -54,12 +53,6 @@ CONFIGURE_ARGS += \
|
|||
--disable-coverage \
|
||||
--disable-sasl
|
||||
|
||||
TARGET_CFLAGS += \
|
||||
-std=gnu99
|
||||
|
||||
TARGET_LDFLAGS = \
|
||||
-L$(STAGING_DIR)/usr/lib/libevent -L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib
|
||||
|
||||
define Package/memcached/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/memcached $(1)/usr/bin/
|
||||
|
|
|
@ -1,25 +0,0 @@
|
|||
Index: memcached-1.4.26/memcached.c
|
||||
===================================================================
|
||||
--- memcached-1.4.26.orig/memcached.c
|
||||
+++ memcached-1.4.26/memcached.c
|
||||
@@ -13,6 +13,10 @@
|
||||
* Anatoly Vorobey <mellon@pobox.com>
|
||||
* Brad Fitzpatrick <brad@danga.com>
|
||||
*/
|
||||
+#ifndef __need_IOV_MAX
|
||||
+#define __need_IOV_MAX
|
||||
+#endif
|
||||
+
|
||||
#include "memcached.h"
|
||||
#include <sys/stat.h>
|
||||
#include <sys/socket.h>
|
||||
@@ -30,9 +34,6 @@
|
||||
#define _P1003_1B_VISIBLE
|
||||
#endif
|
||||
/* need this to get IOV_MAX on some platforms. */
|
||||
-#ifndef __need_IOV_MAX
|
||||
-#define __need_IOV_MAX
|
||||
-#endif
|
||||
#include <pwd.h>
|
||||
#include <sys/mman.h>
|
||||
#include <fcntl.h>
|
Loading…
Reference in a new issue