shairport-sync: Upgrade to v4.3.2 and add AirPlay2 support
Signed-off-by: Ben Klang <bklang@wirehack.net>
This commit is contained in:
parent
d8dbf36810
commit
7391ca3d49
2 changed files with 5 additions and 39 deletions
|
@ -7,12 +7,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=shairport-sync
|
||||
PKG_VERSION:=3.3.9
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=4.3.2
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/mikebrady/shairport-sync/tar.gz/$(PKG_VERSION)?
|
||||
PKG_HASH:=17990cb2620551caa07a1c3b371889e55803071eaada04e958c356547a7e1795
|
||||
PKG_HASH:=dfb485c0603398032a00e51f84b874749bbf155b257adda3d270d5989de08bfd
|
||||
|
||||
PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>, \
|
||||
Mike Brady <mikebrady@eircom.net>
|
||||
|
@ -29,7 +29,7 @@ define Package/shairport-sync/default
|
|||
SECTION:=sound
|
||||
CATEGORY:=Sound
|
||||
TITLE:=AirPlay compatible audio player
|
||||
DEPENDS:=@AUDIO_SUPPORT +libpthread +alsa-lib +libconfig +libdaemon +libpopt
|
||||
DEPENDS:=@AUDIO_SUPPORT +libpthread +alsa-lib +libconfig +libdaemon +libpopt +libstdcpp +libplist +libsodium +libgcrypt +libffmpeg-full +libuuid +nqptp
|
||||
PROVIDES:=shairport-sync
|
||||
URL:=https://github.com/mikebrady/shairport-sync
|
||||
endef
|
||||
|
@ -78,6 +78,7 @@ endef
|
|||
CONFIGURE_ARGS += \
|
||||
--with-alsa \
|
||||
--with-libdaemon \
|
||||
--with-airplay-2 \
|
||||
--with-metadata
|
||||
|
||||
ifeq ($(BUILD_VARIANT),openssl)
|
||||
|
|
|
@ -1,35 +0,0 @@
|
|||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -23,10 +23,6 @@ else
|
||||
endif
|
||||
endif
|
||||
|
||||
-if USE_APPLE_ALAC
|
||||
- shairport_sync_SOURCES += apple_alac.cpp
|
||||
-endif
|
||||
-
|
||||
if USE_CUSTOMPIDDIR
|
||||
AM_CFLAGS+= \
|
||||
-DPIDDIR=\"$(CUSTOM_PID_DIR)\"
|
||||
@@ -80,11 +76,6 @@ if USE_PA
|
||||
shairport_sync_SOURCES += audio_pa.c
|
||||
endif
|
||||
|
||||
-if USE_CONVOLUTION
|
||||
-shairport_sync_SOURCES += FFTConvolver/AudioFFT.cpp FFTConvolver/FFTConvolver.cpp FFTConvolver/Utilities.cpp FFTConvolver/convolver.cpp
|
||||
-AM_CXXFLAGS += -std=c++11
|
||||
-endif
|
||||
-
|
||||
if USE_DNS_SD
|
||||
shairport_sync_SOURCES += mdns_dns_sd.c
|
||||
endif
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -23,7 +23,6 @@ fi
|
||||
|
||||
# Checks for programs.
|
||||
AC_PROG_CC
|
||||
-AC_PROG_CXX
|
||||
AC_PROG_INSTALL
|
||||
|
||||
PKG_PROG_PKG_CONFIG([0.9.0])
|
Loading…
Reference in a new issue