Bluez: Update to 5.56
Signed-off-by: Johnny Vogels <35307256+jmv2009@users.noreply.github.com>
This commit is contained in:
parent
d653862bd7
commit
7299ba0517
9 changed files with 17 additions and 17 deletions
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=bluez
|
||||
PKG_VERSION:=5.55
|
||||
PKG_VERSION:=5.56
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=@KERNEL/linux/bluetooth/
|
||||
PKG_HASH:=8863717113c4897e2ad3271fc808ea245319e6fd95eed2e934fae8e0894e9b88
|
||||
PKG_HASH:=59c4dba9fc8aae2a6a5f8f12f19bc1b0c2dc27355c7ca3123eed3fe6bd7d0b9d
|
||||
|
||||
PKG_LICENSE:=GPL-2.0-or-later
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
|
@ -111,7 +111,7 @@ endef
|
|||
define Package/bluez-utils/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/tools/bdaddr $(1)/usr/bin/
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/bccmd $(1)/usr/bin/
|
||||
# $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/bccmd $(1)/usr/bin/
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/bluemoon $(1)/usr/bin/
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/btattach $(1)/usr/bin/
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/btmon $(1)/usr/bin/
|
||||
|
|
|
@ -9,7 +9,7 @@ Subject: [PATCH 1/4] bcm43xx: Add bcm43xx-3wire variant
|
|||
|
||||
--- a/tools/hciattach.c
|
||||
+++ b/tools/hciattach.c
|
||||
@@ -1091,6 +1091,9 @@ struct uart_t uart[] = {
|
||||
@@ -1078,6 +1078,9 @@ struct uart_t uart[] = {
|
||||
{ "bcm43xx", 0x0000, 0x0000, HCI_UART_H4, 115200, 3000000,
|
||||
FLOW_CTL, DISABLE_PM, NULL, bcm43xx, NULL },
|
||||
|
||||
|
|
|
@ -10,7 +10,7 @@ Subject: [PATCH 2/4] bcm43xx: The UART speed must be reset after the firmware
|
|||
|
||||
--- a/tools/hciattach_bcm43xx.c
|
||||
+++ b/tools/hciattach_bcm43xx.c
|
||||
@@ -367,11 +367,8 @@ int bcm43xx_init(int fd, int def_speed,
|
||||
@@ -354,11 +354,8 @@ int bcm43xx_init(int fd, int def_speed,
|
||||
return -1;
|
||||
|
||||
if (bcm43xx_locate_patch(FIRMWARE_DIR, chip_name, fw_path)) {
|
||||
|
@ -23,7 +23,7 @@ Subject: [PATCH 2/4] bcm43xx: The UART speed must be reset after the firmware
|
|||
if (bcm43xx_load_firmware(fd, fw_path))
|
||||
return -1;
|
||||
|
||||
@@ -381,6 +378,7 @@ int bcm43xx_init(int fd, int def_speed,
|
||||
@@ -368,6 +365,7 @@ int bcm43xx_init(int fd, int def_speed,
|
||||
return -1;
|
||||
}
|
||||
|
||||
|
|
|
@ -9,7 +9,7 @@ Subject: [PATCH 3/4] Increase firmware load timeout to 30s
|
|||
|
||||
--- a/tools/hciattach.c
|
||||
+++ b/tools/hciattach.c
|
||||
@@ -1240,7 +1240,7 @@ int main(int argc, char *argv[])
|
||||
@@ -1227,7 +1227,7 @@ int main(int argc, char *argv[])
|
||||
{
|
||||
struct uart_t *u = NULL;
|
||||
int detach, printpid, raw, opt, i, n, ld, err;
|
||||
|
|
|
@ -9,7 +9,7 @@ Subject: [PATCH 4/4] Move the 43xx firmware into /lib/firmware
|
|||
|
||||
--- a/tools/hciattach_bcm43xx.c
|
||||
+++ b/tools/hciattach_bcm43xx.c
|
||||
@@ -44,7 +44,7 @@
|
||||
@@ -31,7 +31,7 @@
|
||||
#include "hciattach.h"
|
||||
|
||||
#ifndef FIRMWARE_DIR
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/Makefile.in
|
||||
+++ b/Makefile.in
|
||||
@@ -3212,7 +3212,7 @@ unit_tests = $(am__append_54) unit/test-
|
||||
@@ -3225,7 +3225,7 @@ unit_tests = $(am__append_54) unit/test-
|
||||
@CLIENT_TRUE@ client/gatt.h client/gatt.c
|
||||
|
||||
@CLIENT_TRUE@client_bluetoothctl_LDADD = gdbus/libgdbus-internal.la src/libshared-glib.la \
|
||||
|
@ -9,7 +9,7 @@
|
|||
|
||||
@ZSH_COMPLETIONS_TRUE@zshcompletiondir = $(ZSH_COMPLETIONDIR)
|
||||
@ZSH_COMPLETIONS_TRUE@dist_zshcompletion_DATA = completion/zsh/_bluetoothctl
|
||||
@@ -3450,7 +3450,7 @@ unit_tests = $(am__append_54) unit/test-
|
||||
@@ -3457,7 +3457,7 @@ unit_tests = $(am__append_54) unit/test-
|
||||
|
||||
@MESH_TRUE@@TOOLS_TRUE@tools_meshctl_LDADD = gdbus/libgdbus-internal.la src/libshared-glib.la \
|
||||
@MESH_TRUE@@TOOLS_TRUE@ lib/libbluetooth-internal.la \
|
||||
|
@ -18,7 +18,7 @@
|
|||
|
||||
@MESH_TRUE@@TOOLS_TRUE@tools_mesh_cfgclient_SOURCES = tools/mesh-cfgclient.c \
|
||||
@MESH_TRUE@@TOOLS_TRUE@ tools/mesh/model.h tools/mesh/config-model.h \
|
||||
@@ -3517,7 +3517,7 @@ unit_tests = $(am__append_54) unit/test-
|
||||
@@ -3524,7 +3524,7 @@ unit_tests = $(am__append_54) unit/test-
|
||||
@READLINE_TRUE@ tools/obex-client-tool.c
|
||||
|
||||
@READLINE_TRUE@tools_obex_client_tool_LDADD = lib/libbluetooth-internal.la \
|
||||
|
@ -27,7 +27,7 @@
|
|||
|
||||
@READLINE_TRUE@tools_obex_server_tool_SOURCES = $(gobex_sources) $(btio_sources) \
|
||||
@READLINE_TRUE@ tools/obex-server-tool.c
|
||||
@@ -3526,15 +3526,15 @@ unit_tests = $(am__append_54) unit/test-
|
||||
@@ -3533,15 +3533,15 @@ unit_tests = $(am__append_54) unit/test-
|
||||
@READLINE_TRUE@tools_bluetooth_player_SOURCES = tools/bluetooth-player.c
|
||||
@READLINE_TRUE@tools_bluetooth_player_LDADD = gdbus/libgdbus-internal.la \
|
||||
@READLINE_TRUE@ src/libshared-glib.la \
|
||||
|
@ -46,7 +46,7 @@
|
|||
|
||||
@DEPRECATED_TRUE@@READLINE_TRUE@attrib_gatttool_SOURCES = attrib/gatttool.c attrib/att.c attrib/gatt.c \
|
||||
@DEPRECATED_TRUE@@READLINE_TRUE@ attrib/gattrib.c btio/btio.c \
|
||||
@@ -3543,7 +3543,7 @@ unit_tests = $(am__append_54) unit/test-
|
||||
@@ -3550,7 +3550,7 @@ unit_tests = $(am__append_54) unit/test-
|
||||
@DEPRECATED_TRUE@@READLINE_TRUE@ client/display.h
|
||||
|
||||
@DEPRECATED_TRUE@@READLINE_TRUE@attrib_gatttool_LDADD = lib/libbluetooth-internal.la \
|
||||
|
|
|
@ -1,10 +1,10 @@
|
|||
--- a/src/shared/util.h
|
||||
+++ b/src/shared/util.h
|
||||
@@ -26,6 +26,7 @@
|
||||
@@ -14,6 +14,7 @@
|
||||
#include <alloca.h>
|
||||
#include <byteswap.h>
|
||||
#include <string.h>
|
||||
+#include <endian.h>
|
||||
|
||||
#define ARRAY_SIZE(arr) (sizeof(arr) / sizeof((arr)[0]))
|
||||
|
||||
#define BIT(n) (1 << (n))
|
||||
|
|
|
@ -18,7 +18,7 @@ directly, and to do so it needs the full path of the daemon.
|
|||
|
||||
--- a/Makefile.obexd
|
||||
+++ b/Makefile.obexd
|
||||
@@ -1,12 +1,12 @@
|
||||
@@ -2,12 +2,12 @@
|
||||
if SYSTEMD
|
||||
systemduserunitdir = $(SYSTEMD_USERUNITDIR)
|
||||
systemduserunit_DATA = obexd/src/obex.service
|
||||
|
|
|
@ -34,7 +34,7 @@ This commit prevents the call to btd_adv_manager_refresh for non-LE devices.
|
|||
|
||||
--- a/src/adapter.c
|
||||
+++ b/src/adapter.c
|
||||
@@ -573,7 +573,8 @@ static void settings_changed(struct btd_
|
||||
@@ -557,7 +557,8 @@ static void settings_changed(struct btd_
|
||||
g_dbus_emit_property_changed(dbus_conn, adapter->path,
|
||||
ADAPTER_INTERFACE, "Discoverable");
|
||||
store_adapter_info(adapter);
|
||||
|
|
Loading…
Reference in a new issue