Merge pull request #9037 from MikePetullo/dmapd
dmapd: update to 0.0.82
This commit is contained in:
commit
727d2b5a61
2 changed files with 34 additions and 15 deletions
|
@ -8,7 +8,7 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=dmapd
|
||||
PKG_VERSION:=0.0.81
|
||||
PKG_VERSION:=0.0.82
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
|
||||
|
@ -18,7 +18,7 @@ PKG_LICENSE_FILES:=COPYING
|
|||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://www.flyn.org/projects/dmapd
|
||||
PKG_HASH:=74b56417eaed4fa6cd3b47465819f1f83caffc621b5da302d3c90e58bfb2a932
|
||||
PKG_HASH:=7dc1a10d6c1363491492f159f7864d57194384b8007013088ca3b6c220e9e3f6
|
||||
|
||||
PKG_FIXUP:=autoreconf
|
||||
PKG_INSTALL:=1
|
||||
|
@ -35,10 +35,13 @@ define Package/dmapd
|
|||
USERID:=dmapd=56:dmapd=56
|
||||
endef
|
||||
|
||||
define Package/dmapd/decription
|
||||
define Package/dmapd/description
|
||||
Dmapd is a DMAP server
|
||||
endef
|
||||
|
||||
CONFIGURE_ARGS += \
|
||||
--disable-check
|
||||
|
||||
define Package/dmapd/conffiles
|
||||
/etc/dmapd.conf
|
||||
endef
|
||||
|
|
|
@ -1,17 +1,33 @@
|
|||
diff --git a/configure.ac b/configure.ac
|
||||
index d14e193..645b341 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -233,7 +233,13 @@ else
|
||||
AM_CONDITIONAL(USE_LIBDB, false)
|
||||
@@ -192,18 +192,18 @@ AM_CONDITIONAL(USE_GSTREAMER, test x"$HAVE_GSTREAMER" = "xyes")
|
||||
AC_SUBST(GSTREAMER_CFLAGS)
|
||||
AC_SUBST(GSTREAMER_LIBS)
|
||||
|
||||
-dnl Check for check
|
||||
-PKG_CHECK_MODULES(CHECK, check >= 0.9.4, HAVE_CHECK=yes, HAVE_CHECK=no)
|
||||
-
|
||||
-if test x"$HAVE_CHECK" = "xyes"; then
|
||||
- AC_DEFINE(HAVE_CHECK, 1, [Define if check support is enabled])
|
||||
+dnl Check for check, which dmapd uses for its unit tests
|
||||
+AC_ARG_ENABLE(check, [ --disable-check do not build check support], enable_check=$enableval, enable_check=yes)
|
||||
+if test x$enable_check = xyes; then
|
||||
+ PKG_CHECK_MODULES([CHECK], [check >= 0.9.4],have_check=yes,have_check=no)
|
||||
+ AM_CONDITIONAL(USE_CHECK, test x"$have_check" = "xyes")
|
||||
+ if test "x$have_check" = "xyes"; then
|
||||
+ AC_DEFINE(HAVE_CHECK, 1, [Define if check support is enabled])
|
||||
+ fi
|
||||
+else
|
||||
+ AM_CONDITIONAL(USE_CHECK, false)
|
||||
fi
|
||||
|
||||
-PKG_CHECK_MODULES([CHECK], [check >= 0.9.4],have_check=yes,have_check=no)
|
||||
+dnl Test if --enable-unit-test given
|
||||
+AC_ARG_ENABLE(unit-test, [AC_HELP_STRING([--enable-unit-test],[enable unit test])])
|
||||
+if test "x$enable_unit_test" = "xyes" ; then
|
||||
+ PKG_CHECK_MODULES([CHECK], [check >= 0.9.4],have_check=yes,have_check=no)
|
||||
+else
|
||||
+ have_check=no
|
||||
+fi
|
||||
AM_CONDITIONAL(HAVE_CHECK, test x"$have_check" = "xyes")
|
||||
|
||||
-AM_CONDITIONAL(USE_CHECK, test x"$HAVE_CHECK" = "xyes")
|
||||
-
|
||||
-AC_SUBST(CHECK_CFLAGS)
|
||||
-AC_SUBST(CHECK_LIBS)
|
||||
-
|
||||
AM_CONDITIONAL(FLYN, test "$FLYN")
|
||||
|
||||
AC_OUTPUT([
|
||||
|
|
Loading…
Reference in a new issue