Merge pull request #16635 from mhei/21.02-php7-update
[21.02] php7: update to 7.4.23
This commit is contained in:
commit
7268909184
3 changed files with 26 additions and 6 deletions
|
@ -6,8 +6,8 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=php
|
||||
PKG_VERSION:=7.4.22
|
||||
PKG_RELEASE:=1
|
||||
PKG_VERSION:=7.4.23
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_MAINTAINER:=Michael Heimpold <mhei@heimpold.de>
|
||||
PKG_LICENSE:=PHP-3.01
|
||||
|
@ -16,7 +16,7 @@ PKG_CPE_ID:=cpe:/a:php:php
|
|||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=http://www.php.net/distributions/
|
||||
PKG_HASH:=8e078cd7d2f49ac3fcff902490a5bb1addc885e7e3b0d8dd068f42c68297bde8
|
||||
PKG_HASH:=cea52313fcffe56343bcd3c66dbb23cd5507dc559cc2e3547cf8f5452e88a05d
|
||||
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
PKG_USE_MIPS16:=0
|
||||
|
@ -528,6 +528,26 @@ define Package/php7-fpm/conffiles
|
|||
/etc/config/php7-fpm
|
||||
endef
|
||||
|
||||
define Package/php7-mod-openssl/postinst
|
||||
#!/bin/sh
|
||||
[ -n "$$IPKG_INSTROOT" ] || {
|
||||
if [ -e "/etc/php7/20_openssl.ini" ] && [ -e "/etc/php7/15_openssl.ini" ]; then
|
||||
echo "Renaming PHP ini file '/etc/php7/20_openssl.ini' -> '/etc/php7/15_openssl.ini'"
|
||||
mv /etc/php7/20_openssl.ini /etc/php7/15_openssl.ini
|
||||
fi
|
||||
}
|
||||
endef
|
||||
|
||||
define Package/php7-mod-mysqli/postinst
|
||||
#!/bin/sh
|
||||
[ -n "$$IPKG_INSTROOT" ] || {
|
||||
if [ -e "/etc/php7/20_mysqli.ini" ] && [ -e "/etc/php7/30_mysqli.ini" ]; then
|
||||
echo "Renaming PHP ini file '/etc/php7/20_mysqli.ini' -> '/etc/php7/30_mysqli.ini'"
|
||||
mv /etc/php7/20_mysqli.ini /etc/php7/30_mysqli.ini
|
||||
fi
|
||||
}
|
||||
endef
|
||||
|
||||
define Build/Prepare
|
||||
$(call Build/Prepare/Default)
|
||||
$(if $(QUILT),,( cd $(PKG_BUILD_DIR); touch configure.ac; ./buildconf --force ))
|
||||
|
|
|
@ -15,7 +15,7 @@ To be used in tandem with use_embedded_timezonedb.patch and use_embedded_timezon
|
|||
|
||||
--- a/ext/date/php_date.c
|
||||
+++ b/ext/date/php_date.c
|
||||
@@ -1032,6 +1032,23 @@ static char* guess_timezone(const timeli
|
||||
@@ -1039,6 +1039,23 @@ static char* guess_timezone(const timeli
|
||||
DATEG(timezone_valid) = 1;
|
||||
return DATEG(default_timezone);
|
||||
}
|
||||
|
|
|
@ -47,7 +47,7 @@ Subject: Add patch to remove build timestamps from generated binaries.
|
|||
*aix*)
|
||||
--- a/sapi/cgi/cgi_main.c
|
||||
+++ b/sapi/cgi/cgi_main.c
|
||||
@@ -2400,9 +2400,9 @@ parent_loop_end:
|
||||
@@ -2401,9 +2401,9 @@ parent_loop_end:
|
||||
SG(headers_sent) = 1;
|
||||
SG(request_info).no_headers = 1;
|
||||
#if ZEND_DEBUG
|
||||
|
@ -74,7 +74,7 @@ Subject: Add patch to remove build timestamps from generated binaries.
|
|||
#else
|
||||
--- a/sapi/fpm/fpm/fpm_main.c
|
||||
+++ b/sapi/fpm/fpm/fpm_main.c
|
||||
@@ -1717,9 +1717,9 @@ int main(int argc, char *argv[])
|
||||
@@ -1718,9 +1718,9 @@ int main(int argc, char *argv[])
|
||||
SG(request_info).no_headers = 1;
|
||||
|
||||
#if ZEND_DEBUG
|
||||
|
|
Loading…
Reference in a new issue