Merge pull request #13079 from neheb/oor
oor: fix compilation with GCC 10
This commit is contained in:
commit
720b5117fb
2 changed files with 28 additions and 3 deletions
|
@ -17,8 +17,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=oor
|
||||
PKG_VERSION:=1.3.0
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_RELEASE:=3
|
||||
|
||||
PKG_SOURCE_URL=https://github.com/OpenOverlayRouter/oor/releases/download/$(PKG_VERSION)/
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
|
@ -58,4 +57,4 @@ define Package/oor/install
|
|||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/openWRT/openwrt.init.script $(1)/etc/init.d/oor
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,oor))
|
||||
$(eval $(call BuildPackage,oor))
|
||||
|
|
26
net/oor/patches/010-gcc10.patch
Normal file
26
net/oor/patches/010-gcc10.patch
Normal file
|
@ -0,0 +1,26 @@
|
|||
--- a/oor/data-plane/tun/tun.c
|
||||
+++ b/oor/data-plane/tun/tun.c
|
||||
@@ -53,6 +53,8 @@ int tun_rm_fwd_from_entry(lisp_addr_t *eid_prefix, uint8_t is_local);
|
||||
tun_dplane_data_t * tun_dplane_data_new_init(oor_encap_t encap_type, glist_t *allowed_dst_eids);
|
||||
void tun_dplane_data_free(tun_dplane_data_t *data);
|
||||
|
||||
+int tun_receive_fd;
|
||||
+int tun_ifindex;
|
||||
|
||||
data_plane_struct_t dplane_tun = {
|
||||
.datap_init = tun_configure_data_plane,
|
||||
--- a/oor/data-plane/tun/tun.h
|
||||
+++ b/oor/data-plane/tun/tun.h
|
||||
@@ -60,9 +60,9 @@
|
||||
|
||||
/* Tun MN variables */
|
||||
|
||||
-int tun_receive_fd;
|
||||
-int tun_ifindex;
|
||||
-uint8_t *tun_receive_buf;
|
||||
+extern int tun_receive_fd;
|
||||
+extern int tun_ifindex;
|
||||
+extern uint8_t *tun_receive_buf;
|
||||
|
||||
lisp_addr_t * tun_get_default_output_address(int afi);
|
||||
int tun_get_default_output_socket(int);
|
Loading…
Reference in a new issue