libpsl: update to 0.21.2
Signed-off-by: W. Michael Petullo <mike@flyn.org>
This commit is contained in:
parent
d6f6a393df
commit
71fb98ea45
3 changed files with 3 additions and 47 deletions
|
@ -6,12 +6,12 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=libpsl
|
PKG_NAME:=libpsl
|
||||||
PKG_VERSION:=0.21.1
|
PKG_VERSION:=0.21.2
|
||||||
PKG_RELEASE:=3
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=https://github.com/rockdaboot/libpsl/releases/download/$(PKG_VERSION)
|
PKG_SOURCE_URL:=https://github.com/rockdaboot/libpsl/releases/download/$(PKG_VERSION)
|
||||||
PKG_HASH:=ac6ce1e1fbd4d0254c4ddb9d37f1fa99dec83619c1253328155206b896210d4c
|
PKG_HASH:=e35991b6e17001afa2c0ca3b10c357650602b92596209b7492802f3768a6285f
|
||||||
|
|
||||||
PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
|
PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
|
||||||
PKG_LICENSE:=MIT
|
PKG_LICENSE:=MIT
|
||||||
|
@ -34,10 +34,6 @@ define Package/libpsl/description
|
||||||
C library to handle the Public Suffix List
|
C library to handle the Public Suffix List
|
||||||
endef
|
endef
|
||||||
|
|
||||||
MESON_ARGS += \
|
|
||||||
-Druntime=libidn2 \
|
|
||||||
-Dbuiltin=libidn2
|
|
||||||
|
|
||||||
define Build/InstallDev
|
define Build/InstallDev
|
||||||
$(INSTALL_DIR) $(1)/usr/include $(1)/usr/lib $(1)/usr/lib/pkgconfig
|
$(INSTALL_DIR) $(1)/usr/include $(1)/usr/lib $(1)/usr/lib/pkgconfig
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/libpsl.h $(1)/usr/include/
|
$(CP) $(PKG_INSTALL_DIR)/usr/include/libpsl.h $(1)/usr/include/
|
||||||
|
|
|
@ -1,11 +0,0 @@
|
||||||
--- a/meson.build
|
|
||||||
+++ b/meson.build
|
|
||||||
@@ -131,7 +131,7 @@ if psl_test_file == ''
|
|
||||||
psl_test_file = join_paths(meson.current_source_dir(), 'list', 'tests', 'tests.txt')
|
|
||||||
endif
|
|
||||||
|
|
||||||
-python = import('python').find_installation()
|
|
||||||
+python = 'python3'
|
|
||||||
pkgconfig = import('pkgconfig')
|
|
||||||
|
|
||||||
if cc.get_id() == 'msvc'
|
|
|
@ -1,29 +0,0 @@
|
||||||
--- a/meson.build
|
|
||||||
+++ b/meson.build
|
|
||||||
@@ -20,6 +20,7 @@ libicu_dep = notfound
|
|
||||||
libidn_dep = notfound
|
|
||||||
libunistring = notfound
|
|
||||||
networking_deps = notfound
|
|
||||||
+libiconv_dep = notfound
|
|
||||||
|
|
||||||
# FIXME: Cleanup this when Meson gets 'feature-combo':
|
|
||||||
# https://github.com/mesonbuild/meson/issues/4566
|
|
||||||
@@ -86,6 +87,7 @@ endif
|
|
||||||
if libidn2_dep.found() or libidn_dep.found()
|
|
||||||
# Check for libunistring, we need it for psl_str_to_utf8lower()
|
|
||||||
libunistring = cc.find_library('unistring')
|
|
||||||
+ libiconv_dep = dependency('iconv')
|
|
||||||
endif
|
|
||||||
|
|
||||||
if host_machine.system() == 'windows'
|
|
||||||
--- a/src/meson.build
|
|
||||||
+++ b/src/meson.build
|
|
||||||
@@ -19,7 +19,7 @@ cargs = [
|
|
||||||
libpsl = library('psl', sources, suffixes_dafsa_h,
|
|
||||||
include_directories : [configinc, includedir],
|
|
||||||
c_args : cargs,
|
|
||||||
- dependencies : [libidn2_dep, libidn_dep, libicu_dep, libunistring, networking_deps],
|
|
||||||
+ dependencies : [libidn2_dep, libidn_dep, libicu_dep, libunistring, networking_deps, libiconv_dep],
|
|
||||||
version: lt_version,
|
|
||||||
install: true,
|
|
||||||
)
|
|
Loading…
Reference in a new issue