boost: Bump to version 1.76.0
This commit updates boost to version 1.76.0 There are no new libraries in this version More info about Boost 1.76.0 can be found at the usual place [1]. Note: This package update includes a fix merged to Boost.Fiber in [2] which did not make into this version but it will be present in the next one. For now, the patch is needed, but it will be removed in version 1.77.0 [1]: https://www.boost.org/users/history/version_1_76_0.html [2]: https://github.com/boostorg/fiber/pull/276 Signed-off-by: Carlos Miguel Ferreira <carlosmf.pt@gmail.com>
This commit is contained in:
parent
49c7dafae3
commit
7109e2ef1b
3 changed files with 7 additions and 77 deletions
|
@ -11,13 +11,13 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=boost
|
||||
PKG_VERSION:=1.75.0
|
||||
PKG_SOURCE_VERSION:=1_75_0
|
||||
PKG_RELEASE:=3
|
||||
PKG_VERSION:=1.76.0
|
||||
PKG_SOURCE_VERSION:=1_76_0
|
||||
PKG_RELEASE:=$(AUTORELEASE)
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)_$(PKG_SOURCE_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=@SF/$(PKG_NAME)/$(PKG_NAME)/$(PKG_VERSION) https://dl.bintray.com/boostorg/release/$(PKG_VERSION)/source/
|
||||
PKG_HASH:=953db31e016db7bb207f11432bef7df100516eeb746843fa0486a222e3fd49cb
|
||||
PKG_HASH:=f0397ba6e982c4450f27bf32a2a83292aba035b827a5623a14636ea583318c41
|
||||
|
||||
PKG_MAINTAINER:=Carlos M. Ferreira <carlosmf.pt@gmail.com>
|
||||
PKG_LICENSE:=BSL-1.0
|
||||
|
@ -42,7 +42,7 @@ define Package/boost/Default
|
|||
endef
|
||||
|
||||
define Package/boost/description
|
||||
This package provides the Boost v1.75.0 libraries.
|
||||
This package provides the Boost v1.76.0 libraries.
|
||||
Boost is a set of free, peer-reviewed, portable C++ source libraries.
|
||||
|
||||
This package provides the following run-time libraries:
|
||||
|
@ -77,7 +77,7 @@ This package provides the following run-time libraries:
|
|||
- wave
|
||||
|
||||
There are many more header-only libraries supported by Boost.
|
||||
See more at http://www.boost.org/doc/libs/1_75_0/
|
||||
See more at http://www.boost.org/doc/libs/1_76_0/
|
||||
endef
|
||||
|
||||
PKG_BUILD_DEPENDS:=boost/host
|
||||
|
|
|
@ -4,7 +4,7 @@
|
|||
# else
|
||||
# define cpu_relax() asm volatile ("nop" ::: "memory");
|
||||
# endif
|
||||
-#elif BOOST_ARCH_MIPS && (__mips_isa_rev > 1)
|
||||
-#elif BOOST_ARCH_MIPS && (__mips_isa_rev > 1) && !defined(_MIPS_ARCH_OCTEONP)
|
||||
+#elif BOOST_ARCH_MIPS && (((__mips_isa_rev > 1) && defined(__mips32)) || ((__mips_isa_rev > 2) && defined(__mips64)))
|
||||
# define cpu_relax() asm volatile ("pause" ::: "memory");
|
||||
#elif BOOST_ARCH_PPC
|
|
@ -1,70 +0,0 @@
|
|||
--- a/libs/context/src/asm/jump_mips64_n64_elf_gas.S
|
||||
+++ b/libs/context/src/asm/jump_mips64_n64_elf_gas.S
|
||||
@@ -67,7 +67,7 @@ jump_fcontext:
|
||||
sd $ra, 144($sp) # save RA
|
||||
sd $ra, 152($sp) # save RA as PC
|
||||
|
||||
-
|
||||
+#if defined(__mips_hard_float)
|
||||
s.d $f24, 0($sp) # save F24
|
||||
s.d $f25, 8($sp) # save F25
|
||||
s.d $f26, 16($sp) # save F26
|
||||
@@ -76,6 +76,7 @@ jump_fcontext:
|
||||
s.d $f29, 40($sp) # save F29
|
||||
s.d $f30, 48($sp) # save F30
|
||||
s.d $f31, 56($sp) # save F31
|
||||
+#endif
|
||||
|
||||
# store SP (pointing to old context-data) in v0 as return
|
||||
move $v0, $sp
|
||||
@@ -83,6 +84,7 @@ jump_fcontext:
|
||||
# get SP (pointing to new context-data) from a0 param
|
||||
move $sp, $a0
|
||||
|
||||
+#if defined(__mips_hard_float)
|
||||
l.d $f24, 0($sp) # restore F24
|
||||
l.d $f25, 8($sp) # restore F25
|
||||
l.d $f26, 16($sp) # restore F26
|
||||
@@ -91,6 +93,7 @@ jump_fcontext:
|
||||
l.d $f29, 40($sp) # restore F29
|
||||
l.d $f30, 48($sp) # restore F30
|
||||
l.d $f31, 56($sp) # restore F31
|
||||
+#endif
|
||||
|
||||
ld $s0, 64($sp) # restore S0
|
||||
ld $s1, 72($sp) # restore S1
|
||||
--- a/libs/context/src/asm/ontop_mips64_n64_elf_gas.S
|
||||
+++ b/libs/context/src/asm/ontop_mips64_n64_elf_gas.S
|
||||
@@ -67,7 +67,7 @@ ontop_fcontext:
|
||||
sd $ra, 144($sp) # save RA
|
||||
sd $ra, 152($sp) # save RA as PC
|
||||
|
||||
-
|
||||
+#if defined(__mips_hard_float)
|
||||
s.d $f24, 0($sp) # save F24
|
||||
s.d $f25, 8($sp) # save F25
|
||||
s.d $f26, 16($sp) # save F26
|
||||
@@ -76,6 +76,7 @@ ontop_fcontext:
|
||||
s.d $f29, 40($sp) # save F29
|
||||
s.d $f30, 48($sp) # save F30
|
||||
s.d $f31, 56($sp) # save F31
|
||||
+#endif
|
||||
|
||||
# store SP (pointing to context-data) in t0
|
||||
move $t0, $sp
|
||||
@@ -83,6 +84,7 @@ ontop_fcontext:
|
||||
# restore SP (pointing to context-data) from a0
|
||||
move $sp, $a0
|
||||
|
||||
+#if defined(__mips_hard_float)
|
||||
l.d $f24, 0($sp) # restore F24
|
||||
l.d $f25, 8($sp) # restore F25
|
||||
l.d $f26, 16($sp) # restore F26
|
||||
@@ -91,6 +93,7 @@ ontop_fcontext:
|
||||
l.d $f29, 40($sp) # restore F29
|
||||
l.d $f30, 48($sp) # restore F30
|
||||
l.d $f31, 56($sp) # restore F31
|
||||
+#endif
|
||||
|
||||
ld $s0, 64($sp) # restore S0
|
||||
ld $s1, 72($sp) # restore S1
|
Loading…
Reference in a new issue