yara: Update to 3.11.0
Fixed license information. Several Makefile rearrangements for consistency between packages. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
1b4f838815
commit
70be5dbfc6
2 changed files with 7 additions and 29 deletions
|
@ -8,18 +8,21 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=yara
|
||||
PKG_VERSION:=3.10.0
|
||||
PKG_VERSION:=3.11.0
|
||||
PKG_RELEASE:=1
|
||||
PKG_LICENSE:=BSD-3-Clause
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/VirusTotal/yara/tar.gz/v$(PKG_VERSION)?
|
||||
PKG_HASH:=3281d43d6b49a4ca8d3a5d2521e06a0b72863702022f981b051856c2b83449c2
|
||||
PKG_HASH:=de8c54028c848751c06f5acc3b749c3ef6b111090b39f6ff991295af44bd4633
|
||||
|
||||
PKG_MAINTAINER:=Marko Ratkaj <marko.ratkaj@sartura.hr>
|
||||
PKG_LICENSE:=BSD-3-Clause
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
PKG_CPE_ID:=cpe:/a:virustotal:yara
|
||||
|
||||
PKG_FIXUP:=autoreconf
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
PKG_INSTALL:=1
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
|
@ -28,7 +31,6 @@ define Package/yara
|
|||
CATEGORY:=Utilities
|
||||
TITLE:=Pattern matching swiss knife for malware researchers
|
||||
URL:=http://virustotal.github.io/yara/
|
||||
MAINTAINER:=Marko Ratkaj <marko.ratkaj@sartura.hr>
|
||||
DEPENDS:= +libopenssl
|
||||
DEPENDS+= +YARA_module_magic:file
|
||||
DEPENDS+= +YARA_module_cuckoo:jansson
|
||||
|
|
|
@ -1,24 +0,0 @@
|
|||
--- a/libyara/modules/pe.c
|
||||
+++ b/libyara/modules/pe.c
|
||||
@@ -42,6 +42,8 @@ SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
#include <openssl/x509.h>
|
||||
#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
|
||||
#define X509_get_signature_nid(o) OBJ_obj2nid((o)->sig_alg->algorithm)
|
||||
+#define X509_getm_notBefore X509_get_notBefore
|
||||
+#define X509_getm_notAfter X509_get_notAfter
|
||||
#endif
|
||||
#endif
|
||||
|
||||
@@ -1326,10 +1328,10 @@ void pe_parse_certificates(
|
||||
}
|
||||
}
|
||||
|
||||
- date_time = ASN1_get_time_t(X509_get_notBefore(cert));
|
||||
+ date_time = ASN1_get_time_t(X509_getm_notBefore(cert));
|
||||
set_integer(date_time, pe->object, "signatures[%i].not_before", counter);
|
||||
|
||||
- date_time = ASN1_get_time_t(X509_get_notAfter(cert));
|
||||
+ date_time = ASN1_get_time_t(X509_getm_notAfter(cert));
|
||||
set_integer(date_time, pe->object, "signatures[%i].not_after", counter);
|
||||
|
||||
counter++;
|
Loading…
Reference in a new issue