Merge pull request #10520 from Kulipator/libmraa_ramips_fix
[18.06] Libmraa compilation fix
This commit is contained in:
commit
70a990ac45
3 changed files with 6 additions and 6 deletions
|
@ -8,14 +8,14 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=libmraa
|
PKG_NAME:=libmraa
|
||||||
PKG_VERSION:=0.8.0
|
PKG_VERSION:=0.8.1
|
||||||
|
|
||||||
PKG_RELEASE=$(PKG_SOURCE_VERSION)
|
PKG_RELEASE=$(PKG_SOURCE_VERSION)
|
||||||
|
|
||||||
PKG_SOURCE_PROTO:=git
|
PKG_SOURCE_PROTO:=git
|
||||||
PKG_SOURCE_URL:=https://github.com/intel-iot-devkit/mraa.git
|
PKG_SOURCE_URL:=https://github.com/intel-iot-devkit/mraa.git
|
||||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
||||||
PKG_SOURCE_VERSION:=70600dece4138b0c0dbaff42f57828f1559cd840
|
PKG_SOURCE_VERSION:=049ba5fa9f2d18ac0ec6729c46916b34998d3c5f
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
|
||||||
PKG_MIRROR_HASH:=9cbda58e7c7790db3d62cee62f399975effcdc2d9688d3d6bb2b4a86748faff9
|
PKG_MIRROR_HASH:=9cbda58e7c7790db3d62cee62f399975effcdc2d9688d3d6bb2b4a86748faff9
|
||||||
PKG_BUILD_DEPENDS:=node python/host swig/host node/host
|
PKG_BUILD_DEPENDS:=node python/host swig/host node/host
|
||||||
|
|
|
@ -21,11 +21,11 @@ Subject: [PATCH 1/4] base
|
||||||
# Make a version file containing the current version from git.
|
# Make a version file containing the current version from git.
|
||||||
-include (GetGitRevisionDescription)
|
-include (GetGitRevisionDescription)
|
||||||
-git_describe (VERSION "--tags")
|
-git_describe (VERSION "--tags")
|
||||||
-if ("x_${VERSION}" STREQUAL "x_GIT-NOTFOUND" OR "x_${VERSION}" STREQUAL "x_HEAD-HASH-NOTFOUND")
|
-if ("x_${VERSION}" STREQUAL "x_GIT-NOTFOUND" OR "x_${VERSION}" STREQUAL "x_HEAD-HASH-NOTFOUND" OR "x_${VERSION}" STREQUAL "x_-128-NOTFOUND")
|
||||||
- message (WARNING " - Install git to compile a production libmraa!")
|
- message (WARNING " - Install git to compile a production libmraa!")
|
||||||
- set (VERSION "v0.8.0-dirty")
|
- set (VERSION "v0.8.1-dirty")
|
||||||
-endif ()
|
-endif ()
|
||||||
+set (VERSION "v0.8.0")
|
+set (VERSION "v0.8.1")
|
||||||
|
|
||||||
message (INFO " - libmraa Version ${VERSION}")
|
message (INFO " - libmraa Version ${VERSION}")
|
||||||
|
|
||||||
|
|
|
@ -655,7 +655,7 @@ Subject: [PATCH 4/4] fixes
|
||||||
b->gpio_count++;
|
b->gpio_count++;
|
||||||
--- a/src/gpio/gpio.c
|
--- a/src/gpio/gpio.c
|
||||||
+++ b/src/gpio/gpio.c
|
+++ b/src/gpio/gpio.c
|
||||||
@@ -113,6 +113,8 @@
|
@@ -114,6 +114,8 @@
|
||||||
close(export);
|
close(export);
|
||||||
}
|
}
|
||||||
|
|
||||||
|
|
Loading…
Reference in a new issue