luasec: Replace -fPIC with $(FPIC)
Currently i386 and the PPC targets have issues linking issues.
https://github.com/openwrt/packages/issues/3319
says that replacing -fPIC with -fpic works.
Patch added to avoid package overriding settings set by toolchain and make
compilation less noisy
Signed-off-by: Rosen Penev <rosenp@gmail.com>
(cherry-picked from cf23dd2eb0
)
This commit is contained in:
parent
9e532f2254
commit
7059f94769
2 changed files with 17 additions and 1 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=luasec
|
||||
PKG_VERSION:=0.6
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://github.com/brunoos/luasec/archive/
|
||||
|
@ -40,6 +40,9 @@ endef
|
|||
define Build/Configure
|
||||
endef
|
||||
|
||||
TARGET_CFLAGS += $(FPIC)
|
||||
TARGET_LDFLAGS += $(FPIC)
|
||||
|
||||
MAKE_FLAGS += \
|
||||
INCDIR="$(TARGET_CPPFLAGS) -I." \
|
||||
LIBDIR="$(TARGET_LDFLAGS) -L./luasocket" \
|
||||
|
|
13
lang/luasec/patches/100-fix-compilation.patch
Normal file
13
lang/luasec/patches/100-fix-compilation.patch
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- a/src/Makefile
|
||||
+++ b/src/Makefile
|
||||
@@ -13,8 +13,8 @@ WARN=-Wall -pedantic
|
||||
BSD_CFLAGS=-O2 -fPIC $(WARN) $(INCDIR) $(DEFS)
|
||||
BSD_LDFLAGS=-O -fPIC -shared $(LIBDIR)
|
||||
|
||||
-LNX_CFLAGS=-O2 -fPIC $(WARN) $(INCDIR) $(DEFS)
|
||||
-LNX_LDFLAGS=-O -fPIC -shared $(LIBDIR)
|
||||
+LNX_CFLAGS=$(INCDIR) $(DEFS)
|
||||
+LNX_LDFLAGS=-shared $(LIBDIR)
|
||||
|
||||
MAC_ENV=env MACOSX_DEPLOYMENT_TARGET='$(MACVER)'
|
||||
MAC_CFLAGS=-O2 -fno-common $(WARN) $(INCDIR) $(DEFS)
|
Loading…
Reference in a new issue