apache: add compile fix for libxml-2.12.x
libxml2 restructured includes, thus another include is now required otherwise build fails. Signed-off-by: Michael Heimpold <mhei@heimpold.de>
This commit is contained in:
parent
a693dd5821
commit
7009c6be73
2 changed files with 11 additions and 1 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=apache
|
||||
PKG_VERSION:=2.4.57
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
PKG_SOURCE_NAME:=httpd
|
||||
|
||||
PKG_SOURCE:=$(PKG_SOURCE_NAME)-$(PKG_VERSION).tar.bz2
|
||||
|
|
10
net/apache/patches/100_compile-fix-libxml2-2.12.x.patch
Normal file
10
net/apache/patches/100_compile-fix-libxml2-2.12.x.patch
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- a/modules/filters/mod_xml2enc.c
|
||||
+++ b/modules/filters/mod_xml2enc.c
|
||||
@@ -35,6 +35,7 @@
|
||||
#endif
|
||||
|
||||
/* libxml2 */
|
||||
+#include <libxml/xmlstring.h>
|
||||
#include <libxml/encoding.h>
|
||||
|
||||
#if defined(__clang__)
|
Loading…
Reference in a new issue