Merge pull request #13215 from neheb/dcw

libdcwsocket: fix compilation with glibc
This commit is contained in:
Rosen Penev 2020-08-30 23:57:37 -07:00 committed by GitHub
commit 6fd175a4c5
No known key found for this signature in database
GPG key ID: 4AEE18F83AFDEB23
2 changed files with 13 additions and 1 deletions

View file

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libdcwsocket
PKG_VERSION:=1.1.0
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/ewsi/$(PKG_NAME)/tar.gz/v$(PKG_VERSION)?

View file

@ -0,0 +1,12 @@
--- a/src/dcwsocket.c.linux
+++ b/src/dcwsocket.c.linux
@@ -36,6 +36,9 @@
#include <linux/filter.h>
#include <arpa/inet.h>
+#ifndef SO_ATTACH_FILTER
+#define SO_ATTACH_FILTER 26
+#endif
#define ETHER_HEADERSIZE 14
#define CL3_HEADERSIZE 4