commit
6dab28159b
4 changed files with 9 additions and 44 deletions
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=shadow
|
||||
PKG_VERSION:=4.2.1
|
||||
PKG_RELEASE:=8
|
||||
PKG_VERSION:=4.6
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=http://pkg-shadow.alioth.debian.org/releases
|
||||
PKG_HASH:=3b0893d1476766868cd88920f4f1231c4795652aa407569faff802bcda0f3d41
|
||||
PKG_SOURCE_URL:=https://github.com/shadow-maint/shadow/releases/download/$(PKG_VERSION)
|
||||
PKG_HASH:=0998c8d84242a231ab0acb7f8613927ff5bcff095f8aa6b79478893a03f05583
|
||||
PKG_MAINTAINER:=Steven Barth <cyrus@openwrt.org>
|
||||
PKG_LICENSE:=BSD-3-Clause
|
||||
|
||||
|
@ -44,7 +44,7 @@ define Package/shadow/Default
|
|||
SECTION:=utils
|
||||
CATEGORY:=Utilities
|
||||
TITLE:=The PLD Linux shadow utilities
|
||||
URL:=http://pkg-shadow.alioth.debian.org/
|
||||
URL:=https://github.com/shadow-maint/shadow
|
||||
endef
|
||||
|
||||
define Package/shadow
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/configure.in
|
||||
+++ b/configure.in
|
||||
@@ -197,7 +197,6 @@ dnl XXX - quick hack, should disappear b
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -200,7 +200,6 @@ dnl XXX - quick hack, should disappear b
|
||||
AC_DEFINE(USE_SYSLOG, 1, [Define to use syslog().])
|
||||
if test "$ac_cv_func_ruserok" = "yes"; then
|
||||
AC_DEFINE(RLOGIN, 1, [Define if login should support the -r flag for rlogind.])
|
||||
|
|
|
@ -1,35 +0,0 @@
|
|||
From 2cb54158b80cdbd97ca3b36df83f9255e923ae3f Mon Sep 17 00:00:00 2001
|
||||
From: James Le Cuirot <chewi@aura-online.co.uk>
|
||||
Date: Sat, 23 Aug 2014 09:46:39 +0100
|
||||
Subject: [PATCH] Check size of uid_t and gid_t using AC_CHECK_SIZEOF
|
||||
|
||||
This built-in check is simpler than the previous method and, most
|
||||
importantly, works when cross-compiling.
|
||||
|
||||
Signed-off-by: Serge Hallyn <serge.hallyn@ubuntu.com>
|
||||
---
|
||||
configure.in | 14 ++++----------
|
||||
1 file changed, 4 insertions(+), 10 deletions(-)
|
||||
|
||||
--- a/configure.in
|
||||
+++ b/configure.in
|
||||
@@ -334,16 +334,10 @@ if test "$enable_subids" != "no"; then
|
||||
dnl
|
||||
dnl FIXME: check if 32 bit UIDs/GIDs are supported by libc
|
||||
dnl
|
||||
- AC_RUN_IFELSE([AC_LANG_SOURCE([
|
||||
-#include <sys/types.h>
|
||||
-int main(void) {
|
||||
- uid_t u;
|
||||
- gid_t g;
|
||||
- return (sizeof u < 4) || (sizeof g < 4);
|
||||
-}
|
||||
- ])], [id32bit="yes"], [id32bit="no"])
|
||||
+ AC_CHECK_SIZEOF([uid_t],, [#include "sys/types.h"])
|
||||
+ AC_CHECK_SIZEOF([gid_t],, [#include "sys/types.h"])
|
||||
|
||||
- if test "x$id32bit" = "xyes"; then
|
||||
+ if test "$ac_cv_sizeof_uid_t" -ge 4 && test "$ac_cv_sizeof_gid_t" -ge 4; then
|
||||
AC_DEFINE(ENABLE_SUBIDS, 1, [Define to support the subordinate IDs.])
|
||||
enable_subids="yes"
|
||||
else
|
|
@ -1,6 +1,6 @@
|
|||
--- a/src/su.c
|
||||
+++ b/src/su.c
|
||||
@@ -1090,8 +1090,12 @@ int main (int argc, char **argv)
|
||||
@@ -1127,8 +1127,12 @@ int main (int argc, char **argv)
|
||||
|
||||
if (fd >= 0) {
|
||||
err = ioctl (fd, TIOCNOTTY, (char *) 0);
|
||||
|
|
Loading…
Reference in a new issue