transmission: Disable webseeding
It causes 100% CPU usage in certain situations. Just disable it. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
50e352a179
commit
6d9ee2ec86
2 changed files with 12 additions and 1 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=transmission
|
PKG_NAME:=transmission
|
||||||
PKG_VERSION:=2.94
|
PKG_VERSION:=2.94
|
||||||
PKG_RELEASE:=7
|
PKG_RELEASE:=8
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||||
PKG_SOURCE_URL:=@GITHUB/transmission/transmission-releases/master
|
PKG_SOURCE_URL:=@GITHUB/transmission/transmission-releases/master
|
||||||
|
|
11
net/transmission/patches/080-disable-webseeding.patch
Normal file
11
net/transmission/patches/080-disable-webseeding.patch
Normal file
|
@ -0,0 +1,11 @@
|
||||||
|
--- a/libtransmission/webseed.c
|
||||||
|
+++ b/libtransmission/webseed.c
|
||||||
|
@@ -516,8 +516,6 @@ webseed_timer_func (evutil_socket_t foo UNUSED, short bar UNUSED, void * vw)
|
||||||
|
if (w->retry_tickcount)
|
||||||
|
++w->retry_tickcount;
|
||||||
|
|
||||||
|
- on_idle (w);
|
||||||
|
-
|
||||||
|
tr_timerAddMsec (w->timer, TR_IDLE_TIMER_MSEC);
|
||||||
|
}
|
||||||
|
|
Loading…
Reference in a new issue